Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-2963

report.xml not found in path with spaces and braces

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: crap4j-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      I am using the crap4j hudson plugin in one of my projects. The ant build puts
      the report.xml into a directory like "(Projektname Build)/dist/crapreport/". I
      tried to configure the plugin to look in that directory but it did not find the
      report. When I changed the build-file to put the report into the workspace root
      and configured accordingly it worked flawlessly. So I suspect that the blanks
      and/or the braces cause problems here.

      A workaround for me is to specify the report location as "**/crapreport/report.xml".

        Attachments

          Activity

          dlindner dlindner added a comment -

          The problem is caused by the spaces in the path. Right now the report file
          pattern is used in an ant FileSet as the parameter "includes".
          From the ant documentation:
          http://ant.apache.org/manual/CoreTypes/fileset.html
          includes comma- or space-separated list of patterns of files that must be
          included; all files are included when omitted.

          Each space is treated as a pattern separator.

          In effect, commas and spaces in the pattern cause side-effects.

          dlindner dlindner added a comment -

          The behaviour of the pattern field has changed now:
          It treats spaces as normal characters and only commas as separators of different
          patterns.
          This enables paths with spaces to be specified directly while maintaining the
          ability to enter multiple patterns.


            People

            • Assignee:
              dlindner dlindner
              Reporter:
              miq miq
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: