Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-30293

Make Subversion plugin support Subversion 1.9

    Details

    • Type: Improvement
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: subversion-plugin
    • Labels:
      None
    • Environment:
      Jenkins 1.627
      subversion-plugin 2.5.2
    • Similar Issues:

      Description

      Updated SVN Repository to 1.9 and Jenkins gets this error when trying to update.

      org.tmatesoft.svn.core.SVNException: svn: E160004: Malformed representation header 'DELTA 16989 3151 41'
      	at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:64)
      	at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:51)
      	at org.tmatesoft.svn.core.internal.io.fs.FSFS.getDirContents(FSFS.java:898)
      	at org.tmatesoft.svn.core.internal.io.fs.FSRevisionNode.getDirEntries(FSRevisionNode.java:607)
      	at org.tmatesoft.svn.core.internal.io.fs.FSRevisionNode.getChildDirNode(FSRevisionNode.java:588)
      	at org.tmatesoft.svn.core.internal.io.fs.FSRoot.openPath(FSRoot.java:96)
      	at org.tmatesoft.svn.core.internal.io.fs.FSRoot.getRevisionNode(FSRoot.java:53)
      	at org.tmatesoft.svn.core.internal.io.fs.FSRoot.checkNodeKind(FSRoot.java:139)
      	at org.tmatesoft.svn.core.internal.io.fs.FSUpdateContext.fakeDirEntry(FSUpdateContext.java:706)
      	at org.tmatesoft.svn.core.internal.io.fs.FSUpdateContext.drive(FSUpdateContext.java:281)
      	at org.tmatesoft.svn.core.internal.io.fs.FSRepository.finishReport(FSRepository.java:559)
      	at org.tmatesoft.svn.core.internal.wc.admin.SVNReporter.report(SVNReporter.java:140)
      	at org.tmatesoft.svn.core.internal.io.fs.FSRepository.update(FSRepository.java:633)
      	at org.tmatesoft.svn.core.internal.wc16.SVNUpdateClient16.update(SVNUpdateClient16.java:507)
      	at org.tmatesoft.svn.core.internal.wc16.SVNUpdateClient16.doUpdate(SVNUpdateClient16.java:364)
      	at org.tmatesoft.svn.core.internal.wc16.SVNUpdateClient16.doUpdate(SVNUpdateClient16.java:274)
      	at org.tmatesoft.svn.core.internal.wc2.old.SvnOldUpdate.run(SvnOldUpdate.java:27)
      	at org.tmatesoft.svn.core.internal.wc2.old.SvnOldUpdate.run(SvnOldUpdate.java:11)
      	at org.tmatesoft.svn.core.internal.wc2.SvnOperationRunner.run(SvnOperationRunner.java:21)
      	at org.tmatesoft.svn.core.wc2.SvnOperationFactory.run(SvnOperationFactory.java:1259)
      	at org.tmatesoft.svn.core.wc2.SvnOperation.run(SvnOperation.java:294)
      	at org.tmatesoft.svn.core.wc.SVNUpdateClient.doUpdate(SVNUpdateClient.java:311)
      	at org.tmatesoft.svn.core.wc.SVNUpdateClient.doUpdate(SVNUpdateClient.java:291)
      	at org.tmatesoft.svn.core.wc.SVNUpdateClient.doUpdate(SVNUpdateClient.java:387)
      	at hudson.scm.subversion.UpdateUpdater$TaskImpl.perform(UpdateUpdater.java:158)
      	at hudson.scm.subversion.WorkspaceUpdater$UpdateTask.delegateTo(WorkspaceUpdater.java:162)
      	at hudson.scm.SubversionSCM$CheckOutTask.perform(SubversionSCM.java:992)
      	at hudson.scm.SubversionSCM$CheckOutTask.invoke(SubversionSCM.java:973)
      	at hudson.scm.SubversionSCM$CheckOutTask.invoke(SubversionSCM.java:949)
      	at hudson.FilePath.act(FilePath.java:991)
      	at hudson.FilePath.act(FilePath.java:969)
      	at hudson.scm.SubversionSCM.checkout(SubversionSCM.java:898)
      	at hudson.scm.SubversionSCM.checkout(SubversionSCM.java:834)
      	at hudson.scm.SCM.checkout(SCM.java:485)
      	at hudson.model.AbstractProject.checkout(AbstractProject.java:1277)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.defaultCheckout(AbstractBuild.java:610)
      	at jenkins.scm.SCMCheckoutStrategy.checkout(SCMCheckoutStrategy.java:86)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:532)
      	at hudson.model.Run.execute(Run.java:1741)
      	at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:531)
      	at hudson.model.ResourceController.execute(ResourceController.java:98)
      	at hudson.model.Executor.run(Executor.java:408)
      ERROR: Subversion update failed
      java.io.IOException
      	at hudson.scm.subversion.UpdateUpdater$TaskImpl.perform(UpdateUpdater.java:212)
      	at hudson.scm.subversion.WorkspaceUpdater$UpdateTask.delegateTo(WorkspaceUpdater.java:162)
      	at hudson.scm.SubversionSCM$CheckOutTask.perform(SubversionSCM.java:992)
      	at hudson.scm.SubversionSCM$CheckOutTask.invoke(SubversionSCM.java:973)
      	at hudson.scm.SubversionSCM$CheckOutTask.invoke(SubversionSCM.java:949)
      	at hudson.FilePath.act(FilePath.java:991)
      	at hudson.FilePath.act(FilePath.java:969)
      	at hudson.scm.SubversionSCM.checkout(SubversionSCM.java:898)
      	at hudson.scm.SubversionSCM.checkout(SubversionSCM.java:834)
      	at hudson.scm.SCM.checkout(SCM.java:485)
      	at hudson.model.AbstractProject.checkout(AbstractProject.java:1277)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.defaultCheckout(AbstractBuild.java:610)
      	at jenkins.scm.SCMCheckoutStrategy.checkout(SCMCheckoutStrategy.java:86)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:532)
      	at hudson.model.Run.execute(Run.java:1741)
      	at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:531)
      	at hudson.model.ResourceController.execute(ResourceController.java:98)
      	at hudson.model.Executor.run(Executor.java:408)
      Caused by: hudson.scm.subversion.UpdaterException: failed to perform svn update
      	... 18 more
      Caused by: org.tmatesoft.svn.core.SVNException: svn: E160004: Malformed representation header 'DELTA 16989 3151 41'
      	at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:64)
      	at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:51)
      	at org.tmatesoft.svn.core.internal.io.fs.FSFS.getDirContents(FSFS.java:898)
      	at org.tmatesoft.svn.core.internal.io.fs.FSRevisionNode.getDirEntries(FSRevisionNode.java:607)
      	at org.tmatesoft.svn.core.internal.io.fs.FSRevisionNode.getChildDirNode(FSRevisionNode.java:588)
      	at org.tmatesoft.svn.core.internal.io.fs.FSRoot.openPath(FSRoot.java:96)
      	at org.tmatesoft.svn.core.internal.io.fs.FSRoot.getRevisionNode(FSRoot.java:53)
      	at org.tmatesoft.svn.core.internal.io.fs.FSRoot.checkNodeKind(FSRoot.java:139)
      	at org.tmatesoft.svn.core.internal.io.fs.FSUpdateContext.fakeDirEntry(FSUpdateContext.java:706)
      	at org.tmatesoft.svn.core.internal.io.fs.FSUpdateContext.drive(FSUpdateContext.java:281)
      	at org.tmatesoft.svn.core.internal.io.fs.FSRepository.finishReport(FSRepository.java:559)
      	at org.tmatesoft.svn.core.internal.wc.admin.SVNReporter.report(SVNReporter.java:140)
      	at org.tmatesoft.svn.core.internal.io.fs.FSRepository.update(FSRepository.java:633)
      	at org.tmatesoft.svn.core.internal.wc16.SVNUpdateClient16.update(SVNUpdateClient16.java:507)
      	at org.tmatesoft.svn.core.internal.wc16.SVNUpdateClient16.doUpdate(SVNUpdateClient16.java:364)
      	at org.tmatesoft.svn.core.internal.wc16.SVNUpdateClient16.doUpdate(SVNUpdateClient16.java:274)
      	at org.tmatesoft.svn.core.internal.wc2.old.SvnOldUpdate.run(SvnOldUpdate.java:27)
      	at org.tmatesoft.svn.core.internal.wc2.old.SvnOldUpdate.run(SvnOldUpdate.java:11)
      	at org.tmatesoft.svn.core.internal.wc2.SvnOperationRunner.run(SvnOperationRunner.java:21)
      	at org.tmatesoft.svn.core.wc2.SvnOperationFactory.run(SvnOperationFactory.java:1259)
      	at org.tmatesoft.svn.core.wc2.SvnOperation.run(SvnOperation.java:294)
      	at org.tmatesoft.svn.core.wc.SVNUpdateClient.doUpdate(SVNUpdateClient.java:311)
      	at org.tmatesoft.svn.core.wc.SVNUpdateClient.doUpdate(SVNUpdateClient.java:291)
      	at org.tmatesoft.svn.core.wc.SVNUpdateClient.doUpdate(SVNUpdateClient.java:387)
      	at hudson.scm.subversion.UpdateUpdater$TaskImpl.perform(UpdateUpdater.java:158)
      	... 17 more
      

        Attachments

          Issue Links

            Activity

            hgomez Henri Gomez added a comment -

            Ticket title shouldn't be "Make Subversion plugin support Subversion 1.9" ?

            leo_ Leo Leung added a comment -

            Oops. Fixed the title now.

            recena Manuel Recena Soto added a comment -

            Leo Leung I don't recommend you to manipulate the working copy manually. Please, let Subversion Plugin manages this.

            rodrigc Craig Rodrigues added a comment -

            Fixed in Subversion plugin 2.5.5, which updates to SVNKit 1.8.11

            After upgrading to this plugin, you need to go to
            Manager Jenkins -> Configure System -> Subversion Workspace version and
            change the default version to 1.8

            1.8 and 1.9 have compatible working copy versions

            recena Manuel Recena Soto added a comment -

            Craig Rodrigues, thanks for your feedback. I forgot to update this issue.

            daschuer Daniel Schürmann added a comment - - edited

            I am still suffering this bug because SubWCRev.exe insists to work only with a 1.9 working copy.

            Edit:
            After setting the working copy format from 1.4 (8) to 1.8 (31) AND deleting the workspace folder it works. (Sorry for the noise)

            It would be nice if you could change working copy format combobox to
            "1.8/1.9 (31)"
            to avoid the confusion in future.


              People

              • Assignee:
                recena Manuel Recena Soto
                Reporter:
                leo_ Leo Leung
              • Votes:
                4 Vote for this issue
                Watchers:
                8 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: