Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-30715

Disk Usage Plugin Crashes Java, Crashes WebSphere Server

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Blocker
    • Resolution: Fixed
    • Component/s: disk-usage-plugin
    • Labels:
    • Environment:
    • Similar Issues:

      Description

      Since the last plugin up the server has crashed 3 out 6 days. The crash is shown as a prompt on the server saying that Java has stopped running. The disk-usage plugin was the only update that has been done to the server.

      Log Name: Application
      Source: Application Error
      Date: 9/29/2015 11:16:55 PM
      Event ID: 1000
      Task Category: (100)
      Level: Error
      Keywords: Classic
      User: N/A
      Computer: [COMPUTERNAME]
      Description:
      Faulting application name: java.exe, version: 7.0.0.0, time stamp: 0x552cec04
      Faulting module name: ntdll.dll, version: 6.1.7601.18933, time stamp: 0x55a6a196
      Exception code: 0xc00000fd
      Fault offset: 0x00000000000510a1
      Faulting process id: 0x36c
      Faulting application start time: 0x01d0fb244f4c8870
      Faulting application path: %WEBSPHERE_DIR%\AppServer\java_1.7.1_64\bin\java.exe
      Faulting module path: C:\Windows\SYSTEM32\ntdll.dll
      Report Id: b348230f-6721-11e5-ab66-005056bd0b0a
      Event Xml:
      <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
      <Provider Name="Application Error" />
      <EventID Qualifiers="0">1000</EventID>
      <Level>2</Level>
      <Task>100</Task>
      <Keywords>0x80000000000000</Keywords>
      <TimeCreated SystemTime="2015-09-30T03:16:55.000000000Z" />
      <EventRecordID>13990</EventRecordID>
      <Channel>Application</Channel>
      <Computer>[COMPUTERNAME]</Computer>
      <Security />
      </System>
      <EventData>
      <Data>java.exe</Data>
      <Data>7.0.0.0</Data>
      <Data>552cec04</Data>
      <Data>ntdll.dll</Data>
      <Data>6.1.7601.18933</Data>
      <Data>55a6a196</Data>
      <Data>c00000fd</Data>
      <Data>00000000000510a1</Data>
      <Data>36c</Data>
      <Data>01d0fb244f4c8870</Data>
      <Data>%WEBSPHERE_DIR%\AppServer\java_1.7.1_64\bin\java.exe</Data>
      <Data>C:\Windows\SYSTEM32\ntdll.dll</Data>
      <Data>b348230f-6721-11e5-ab66-005056bd0b0a</Data>
      </EventData>
      </Event>

        Attachments

          Activity

          bcoveny Bruce Coveny added a comment -

          Downgraded to 0.26 from 0.27 server still crashed, we don't fully rely on this plugin so disabled it all together, server has been stable. Also have noticed on another Jenkins instance that the plugin seems to be out of control lately. within 4 seconds it polled the same project and build id 11 times!

          [10/2/15 9:23:04:222 EDT] 00002088 SystemOut O create build disk usage for build [JOBNAME] #14345 of project [JOBNAME]
          [10/2/15 9:23:04:222 EDT] 00002088 SystemOut O information Id 14345 number 14345 size 0
          [10/2/15 9:23:04:222 EDT] 00002088 SystemOut O create build disk usage for build [JOBNAME] #14345 of project [JOBNAME]
          [10/2/15 9:23:04:222 EDT] 00002088 SystemOut O information Id 14345 number 14345 size 0
          [10/2/15 9:23:04:222 EDT] 00002088 SystemOut O create build disk usage for build [JOBNAME] #14345 of project [JOBNAME]
          [10/2/15 9:23:04:222 EDT] 00002088 SystemOut O information Id 14345 number 14345 size 0
          [10/2/15 9:23:04:222 EDT] 00002088 SystemOut O create build disk usage for build [JOBNAME] #14345 of project [JOBNAME]
          [10/2/15 9:23:04:222 EDT] 00002088 SystemOut O information Id 14345 number 14345 size 0
          [10/2/15 9:23:08:185 EDT] 00002088 SystemOut O create build disk usage for build [JOBNAME] #14345 of project [JOBNAME]
          [10/2/15 9:23:08:185 EDT] 00002088 SystemOut O information Id 14345 number 14345 size 0
          [10/2/15 9:23:08:185 EDT] 00002088 SystemOut O create build disk usage for build [JOBNAME] #14345 of project [JOBNAME]
          [10/2/15 9:23:08:185 EDT] 00002088 SystemOut O information Id 14345 number 14345 size 0
          [10/2/15 9:23:08:185 EDT] 00002088 SystemOut O create build disk usage for build [JOBNAME] #14345 of project [JOBNAME]
          [10/2/15 9:23:08:185 EDT] 00002088 SystemOut O information Id 14345 number 14345 size 0
          [10/2/15 9:23:08:185 EDT] 00002088 SystemOut O create build disk usage for build [JOBNAME] #14345 of project [JOBNAME]
          [10/2/15 9:23:08:185 EDT] 00002088 SystemOut O information Id 14345 number 14345 size 0
          [10/2/15 9:23:08:185 EDT] 00002088 SystemOut O create build disk usage for build [JOBNAME] #14345 of project [JOBNAME]
          [10/2/15 9:23:08:185 EDT] 00002088 SystemOut O information Id 14345 number 14345 size 0
          [10/2/15 9:23:08:185 EDT] 00002088 SystemOut O create build disk usage for build [JOBNAME] #14345 of project [JOBNAME]
          [10/2/15 9:23:08:185 EDT] 00002088 SystemOut O information Id 14345 number 14345 size 0
          [10/2/15 9:23:08:185 EDT] 00002088 SystemOut O create build disk usage for build [JOBNAME] #14345 of project [JOBNAME]
          [10/2/15 9:23:08:185 EDT] 00002088 SystemOut O information Id 14345 number 14345 size 0

          lvotypkova Lucie Votypkova added a comment - - edited

          Hi,
          I do not think that it is the root cause of crashes. I debuged one bug before release and forgot my output which served me for debugging. In version 0.28 it is fixed. In these lines the disk usage is not calculated, it was for creating instance of transient action for build (which is cheap operation). But I do not think that it is the cause. Please do you have some crash log from java? It would really help me.

          bcoveny Bruce Coveny added a comment -

          If you could provide ways of giving more information I am happy to do so. However, this causes a Java crash and it is a prompt on the server stating that Java is not responding. You than have to answer to continue waiting or end program. The information provided is from the event monitor. There is no Java dump or even a core dump from WebSphere that could be provided. The logging on the server all together just stops. We disabled the plugin and after a period of time we had the same issue. We uninstalled in the plugin and the server has been stable since.

          lvotypkova Lucie Votypkova added a comment -

          if it is crash of JVM, you can set the location of log by option -XX:ErrorFile=./hs_err_.log when you start java. If it is crash from out of memory you can see it in log. Please sent me jvm crash log or log of webSphere server (a few last lines will be enough).


            People

            • Assignee:
              lvotypkova Lucie Votypkova
              Reporter:
              bcoveny Bruce Coveny
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: