Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-30857

Java 6 runtime compatibility broken in gerrit-trigger 2.15.1, 2.16

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: gerrit-trigger-plugin
    • Labels:
      None
    • Environment:
      Debian wheezy amd64
      openjdk-6-jre-headless 6b36-1.13.8-1~deb7u1
      jenkins 1.609.3
    • Similar Issues:

      Description

      Hello,

      The commit https://github.com/jenkinsci/gerrit-trigger-plugin/commit/a5d44ea9dc6b42de7aeb63371a42b607e4578fb2 references ReflectiveOperationException, which has been introduced in Java 1.7.

      Since the README.md file states that the plugin should be runtime compatible with Java 6, I think that this can be considered as a bug.

      Best regards,
      Alex

        Attachments

          Activity

          boeglin Alexandre Boeglin added a comment - - edited

          Sorry, forgot to add the related trace:

          Exception in thread "Gerrit Worker EventThread_0" java.lang.NoClassDefFoundError: java/lang/ReflectiveOperationException
                  at com.sonyericsson.hudson.plugins.gerrit.trigger.hudsontrigger.EventListener.createParameters(EventListener.java:253)
                  at com.sonyericsson.hudson.plugins.gerrit.trigger.hudsontrigger.EventListener.schedule(EventListener.java:182)
                  at com.sonyericsson.hudson.plugins.gerrit.trigger.hudsontrigger.EventListener.schedule(EventListener.java:158)
                  at com.sonyericsson.hudson.plugins.gerrit.trigger.hudsontrigger.EventListener.gerritEvent(EventListener.java:100)
                  at com.sonymobile.tools.gerrit.gerritevents.GerritHandler.notifyListener(GerritHandler.java:317)
                  at com.sonymobile.tools.gerrit.gerritevents.GerritHandler.notifyListeners(GerritHandler.java:285)
                  at com.sonyericsson.hudson.plugins.gerrit.trigger.JenkinsAwareGerritHandler.notifyListeners(JenkinsAwareGerritHandler.java:77)
                  at com.sonymobile.tools.gerrit.gerritevents.workers.AbstractGerritEventWork.perform(AbstractGerritEventWork.java:46)
                  at com.sonymobile.tools.gerrit.gerritevents.workers.AbstractJsonObjectWork.perform(AbstractJsonObjectWork.java:77)
                  at com.sonymobile.tools.gerrit.gerritevents.workers.StreamEventsStringWork.perform(StreamEventsStringWork.java:67)
                  at com.sonymobile.tools.gerrit.gerritevents.workers.EventThread.run(EventThread.java:66)
                  at com.sonyericsson.hudson.plugins.gerrit.trigger.SystemEventThread.run(SystemEventThread.java:66)
          Caused by: java.lang.ClassNotFoundException: java.lang.ReflectiveOperationException
                  at jenkins.util.AntClassLoader.findClassInComponents(AntClassLoader.java:1375)
                  at jenkins.util.AntClassLoader.findClass(AntClassLoader.java:1325)
                  at jenkins.util.AntClassLoader.loadClass(AntClassLoader.java:1078)
                  at java.lang.ClassLoader.loadClass(ClassLoader.java:268)
                  ... 12 more
          
          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: David Pursehouse
          Path:
          src/main/java/com/sonyericsson/hudson/plugins/gerrit/trigger/hudsontrigger/GerritTriggerParameters.java
          http://jenkins-ci.org/commit/gerrit-trigger-plugin/7dee0c2967c6ba5fc7f2ef0052649d7c22e7c714
          Log:
          Don't used ReflectiveOperationException

          Using ReflectiveOperationException breaks Java 6 runtime compatibility.

          [FIXED JENKINS-30857]

          Change-Id: Ic8c88102cf9ef3a3286f5311d1b3ed661ac2d77c

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Robert Sandell
          Path:
          src/main/java/com/sonyericsson/hudson/plugins/gerrit/trigger/hudsontrigger/GerritTriggerParameters.java
          http://jenkins-ci.org/commit/gerrit-trigger-plugin/b52fd7d945217d2f0c90698bcb68e56af0f519fa
          Log:
          Merge pull request #276 from dpursehouse/JENKINS-30857

          Don't used ReflectiveOperationException

          Compare: https://github.com/jenkinsci/gerrit-trigger-plugin/compare/963b25f6dda0...b52fd7d94521


            People

            • Assignee:
              rsandell rsandell
              Reporter:
              boeglin Alexandre Boeglin
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: