Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-30898

Ruby Runtime Plugin - org.jruby.util.collections.WeakHashSet not found

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: ruby-runtime-plugin
    • Labels:
      None
    • Environment:
      Jenkins ver. 1.633, OpenJDK 1.7.0_79, Ubuntu 14.04.3 LTS
    • Similar Issues:

      Description

      I can't install Ruby Runtime Plugin.
      Failure reason:

      java.io.IOException: Failed to dynamically deploy this plugin
      	at hudson.model.UpdateCenter$InstallationJob._run(UpdateCenter.java:1328)
      	at hudson.model.UpdateCenter$DownloadJob.run(UpdateCenter.java:1126)
      	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
      	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
      	at hudson.remoting.AtmostOneThreadExecutor$Worker.run(AtmostOneThreadExecutor.java:110)
      	at java.lang.Thread.run(Thread.java:745)
      Caused by: java.io.IOException: Failed to install ruby-runtime plugin
      	at hudson.PluginManager.dynamicLoad(PluginManager.java:487)
      	at hudson.model.UpdateCenter$InstallationJob._run(UpdateCenter.java:1324)
      	... 5 more
      Caused by: java.io.IOException: Failed to initialize
      	at hudson.ClassicPluginStrategy.load(ClassicPluginStrategy.java:441)
      	at hudson.PluginManager.dynamicLoad(PluginManager.java:478)
      	... 6 more
      Caused by: java.lang.RuntimeException: java.lang.ClassNotFoundException: org.jruby.util.collections.WeakHashSet
      	at org.kohsuke.asm5.ClassWriter.getCommonSuperClass(ClassWriter.java:1684)
      	at org.kohsuke.asm5.ClassWriter.getMergedType(ClassWriter.java:1654)
      	at org.kohsuke.asm5.Frame.merge(Frame.java:1426)
      	at org.kohsuke.asm5.Frame.merge(Frame.java:1325)
      	at org.kohsuke.asm5.MethodWriter.visitMaxs(MethodWriter.java:1475)
      	at org.kohsuke.asm5.tree.MethodNode.accept(MethodNode.java:833)
      	at org.kohsuke.asm5.commons.JSRInlinerAdapter.visitEnd(JSRInlinerAdapter.java:187)
      	at org.kohsuke.asm5.MethodVisitor.visitEnd(MethodVisitor.java:877)
      	at org.kohsuke.asm5.ClassReader.readMethod(ClassReader.java:1021)
      	at org.kohsuke.asm5.ClassReader.accept(ClassReader.java:693)
      	at org.kohsuke.asm5.ClassReader.accept(ClassReader.java:506)
      	at org.jenkinsci.bytecode.Transformer.transform(Transformer.java:76)
      	at hudson.ClassicPluginStrategy$AntClassLoader2.defineClassFromData(ClassicPluginStrategy.java:800)
      	at jenkins.util.AntClassLoader.getClassFromStream(AntClassLoader.java:1310)
      	at jenkins.util.AntClassLoader.findClassInComponents(AntClassLoader.java:1366)
      	at jenkins.util.AntClassLoader.findClass(AntClassLoader.java:1326)
      	at jenkins.util.AntClassLoader.loadClass(AntClassLoader.java:1079)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
      	at org.jenkinsci.jruby.RubyClassConverter.<init>(RubyClassConverter.java:12)
      	at org.jenkinsci.jruby.JRubyXStream.register(JRubyXStream.java:25)
      	at ruby.RubyRuntimePlugin.initRubyXStreams(RubyRuntimePlugin.java:44)
      	at ruby.RubyRuntimePlugin.start(RubyRuntimePlugin.java:28)
      	at hudson.ClassicPluginStrategy.startPlugin(ClassicPluginStrategy.java:449)
      	at hudson.ClassicPluginStrategy.load(ClassicPluginStrategy.java:438)
      	... 7 more
      

        Attachments

          Issue Links

            Activity

            henres Henri Auvigny added a comment - - edited

            Sill have the error on jenkins 1.635:
            Debian: Jessie
            Java:
            java version "1.8.0_66"
            Java(TM) SE Runtime Environment (build 1.8.0_66-b17)
            Java HotSpot(TM) 64-Bit Server VM (build 25.66-b17, mixed mode)

            java.io.IOException: Failed to dynamically deploy this plugin
            at hudson.model.UpdateCenter$InstallationJob._run(UpdateCenter.java:1328)
            at hudson.model.UpdateCenter$DownloadJob.run(UpdateCenter.java:1126)
            at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
            at java.util.concurrent.FutureTask.run(FutureTask.java:266)
            at hudson.remoting.AtmostOneThreadExecutor$Worker.run(AtmostOneThreadExecutor.java:110)
            at java.lang.Thread.run(Thread.java:745)
            Caused by: java.io.IOException: Failed to install ruby-runtime plugin
            at hudson.PluginManager.dynamicLoad(PluginManager.java:487)
            at hudson.model.UpdateCenter$InstallationJob._run(UpdateCenter.java:1324)
            ... 5 more
            Caused by: java.io.IOException: Failed to initialize
            at hudson.ClassicPluginStrategy.load(ClassicPluginStrategy.java:441)
            at hudson.PluginManager.dynamicLoad(PluginManager.java:478)
            ... 6 more
            Caused by: java.lang.ClassCircularityError: org/jruby/RubyClass
            at java.lang.Class.forName0(Native Method)
            at java.lang.Class.forName(Class.java:348)
            at org.jenkinsci.bytecode.ClassWriter.loadClass(ClassWriter.java:97)
            at org.jenkinsci.bytecode.ClassWriter.getCommonSuperClass(ClassWriter.java:64)
            at org.kohsuke.asm5.ClassWriter.getMergedType(ClassWriter.java:1654)
            at org.kohsuke.asm5.Frame.merge(Frame.java:1426)
            at org.kohsuke.asm5.Frame.merge(Frame.java:1374)
            at org.kohsuke.asm5.MethodWriter.visitMaxs(MethodWriter.java:1475)
            at org.kohsuke.asm5.tree.MethodNode.accept(MethodNode.java:833)
            at org.kohsuke.asm5.commons.JSRInlinerAdapter.visitEnd(JSRInlinerAdapter.java:187)
            at org.jenkinsci.bytecode.Transformer$1$1.visitEnd(Transformer.java:107)
            at org.kohsuke.asm5.MethodVisitor.visitEnd(MethodVisitor.java:877)
            at org.kohsuke.asm5.ClassReader.readMethod(ClassReader.java:1021)
            at org.kohsuke.asm5.ClassReader.accept(ClassReader.java:693)
            at org.kohsuke.asm5.ClassReader.accept(ClassReader.java:506)
            at org.jenkinsci.bytecode.Transformer.transform(Transformer.java:113)
            at hudson.ClassicPluginStrategy$AntClassLoader2.defineClassFromData(ClassicPluginStrategy.java:800)
            at jenkins.util.AntClassLoader.getClassFromStream(AntClassLoader.java:1310)
            at jenkins.util.AntClassLoader.findClassInComponents(AntClassLoader.java:1366)
            at jenkins.util.AntClassLoader.findClass(AntClassLoader.java:1326)
            at jenkins.util.AntClassLoader.loadClass(AntClassLoader.java:1079)
            at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
            at org.jenkinsci.jruby.RubyClassConverter.<init>(RubyClassConverter.java:12)
            at org.jenkinsci.jruby.JRubyXStream.register(JRubyXStream.java:25)
            at ruby.RubyRuntimePlugin.initRubyXStreams(RubyRuntimePlugin.java:44)
            at ruby.RubyRuntimePlugin.start(RubyRuntimePlugin.java:28)
            at hudson.ClassicPluginStrategy.startPlugin(ClassicPluginStrategy.java:449)
            at hudson.ClassicPluginStrategy.load(ClassicPluginStrategy.java:438)
            ... 7 more

            z87 J C added a comment -

            I'm getting the same issue in 1.636-1.1

            jorgenpt Jørgen Tjernø added a comment -

            Hiroshi SHIBATA Yuu Yamashita are set as project maintainers on the plugin page, they might have some input. I am un-assigning myself from this bug as I am no longer the maintainer of the ruby-runtime-plugin.

            mika Michael Prokop added a comment -

            This issue isn't fixed yet, it's still present with Jenkins v1.638:

            INFO: Injecting JRuby into XStream
            Nov 12, 2015 11:18:27 AM jenkins.InitReactorRunner$1 onTaskFailed
            SEVERE: Failed Loading plugin ruby-runtime
            java.io.IOException: Failed to initialize
            at hudson.ClassicPluginStrategy.load(ClassicPluginStrategy.java:441)
            at hudson.PluginManager$2$1$1.run(PluginManager.java:384)
            at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:169)
            at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:282)
            at jenkins.model.Jenkins$8.runTask(Jenkins.java:913)
            at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:210)
            at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117)
            at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
            at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
            at java.lang.Thread.run(Thread.java:745)
            Caused by: java.lang.ClassCircularityError: org/jruby/RubyClass
            at java.lang.Class.forName0(Native Method)
            at java.lang.Class.forName(Class.java:278)
            at org.jenkinsci.bytecode.ClassWriter.loadClass(ClassWriter.java:97)
            at org.jenkinsci.bytecode.ClassWriter.getCommonSuperClass(ClassWriter.java:64)
            at org.kohsuke.asm5.ClassWriter.getMergedType(ClassWriter.java:1654)
            at org.kohsuke.asm5.Frame.merge(Frame.java:1426)
            at org.kohsuke.asm5.Frame.merge(Frame.java:1374)
            at org.kohsuke.asm5.MethodWriter.visitMaxs(MethodWriter.java:1475)
            at org.kohsuke.asm5.tree.MethodNode.accept(MethodNode.java:833)
            at org.kohsuke.asm5.commons.JSRInlinerAdapter.visitEnd(JSRInlinerAdapter.java:187)
            at org.jenkinsci.bytecode.Transformer$1$1.visitEnd(Transformer.java:107)
            at org.kohsuke.asm5.MethodVisitor.visitEnd(MethodVisitor.java:877)
            at org.kohsuke.asm5.ClassReader.readMethod(ClassReader.java:1021)
            at org.kohsuke.asm5.ClassReader.accept(ClassReader.java:693)
            at org.kohsuke.asm5.ClassReader.accept(ClassReader.java:506)
            at org.jenkinsci.bytecode.Transformer.transform(Transformer.java:113)
            at hudson.ClassicPluginStrategy$AntClassLoader2.defineClassFromData(ClassicPluginStrategy.java:800)
            at jenkins.util.AntClassLoader.getClassFromStream(AntClassLoader.java:1310)
            at jenkins.util.AntClassLoader.findClassInComponents(AntClassLoader.java:1366)
            at jenkins.util.AntClassLoader.findClass(AntClassLoader.java:1326)
            at jenkins.util.AntClassLoader.loadClass(AntClassLoader.java:1079)
            at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
            at org.jenkinsci.jruby.RubyClassConverter.<init>(RubyClassConverter.java:12)
            at org.jenkinsci.jruby.JRubyXStream.register(JRubyXStream.java:25)
            at ruby.RubyRuntimePlugin.initRubyXStreams(RubyRuntimePlugin.java:44)
            at ruby.RubyRuntimePlugin.start(RubyRuntimePlugin.java:28)
            at hudson.ClassicPluginStrategy.startPlugin(ClassicPluginStrategy.java:449)
            at hudson.ClassicPluginStrategy.load(ClassicPluginStrategy.java:438)
            ... 9 more

            mika Michael Prokop added a comment -

            Ah, I overlooked that the issue is actually covered in https://issues.jenkins-ci.org/browse/JENKINS-31019, apologies.


              People

              • Assignee:
                Unassigned
                Reporter:
                mwiktorczyk Mariusz Wiktorczyk
              • Votes:
                2 Vote for this issue
                Watchers:
                13 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: