Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-30921

unable to parse NUnit report generated by nunitlite v1.0.0

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Duplicate
    • Component/s: nunit-plugin
    • Labels:
      None
    • Environment:
      Mac OS X Yosemite
    • Similar Issues:

      Description

      Build fails when nunit-plugin attempts to handle the test summary xml file (it is attached) with the following stacktrace:

      2015-10-11 13:52:38.727 TestRunner.iOS[3489:184995] Tests run: 17 Passed: 17 Inconclusive: 0 Failed: 0 Ignored: 1

      Recording NUnit tests results
      ERROR: Publisher 'Publish NUnit test result report' aborted due to exception:

      java.io.IOException: remote file operation failed: /Users/jenkins/workspace/builds/project1/63 at hudson.remoting.Channel@342f3856:macmini1: hudson.util.IOException2: Could not transform the NUnit report. Please report this issue to the plugin author
      at hudson.FilePath.act(FilePath.java:987)
      at hudson.FilePath.act(FilePath.java:969)
      at hudson.plugins.nunit.NUnitPublisher.perform(NUnitPublisher.java:145)
      at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)
      at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:779)
      at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:726)
      at hudson.model.Build$BuildExecution.post2(Build.java:185)
      at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:671)
      at hudson.model.Run.execute(Run.java:1766)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
      at hudson.model.ResourceController.execute(ResourceController.java:98)
      at hudson.model.Executor.run(Executor.java:408)
      Caused by: hudson.util.IOException2: Could not transform the NUnit report. Please report this issue to the plugin author
      at hudson.plugins.nunit.NUnitArchiver.invoke(NUnitArchiver.java:65)
      at hudson.plugins.nunit.NUnitArchiver.invoke(NUnitArchiver.java:26)
      at hudson.FilePath$FileCallableWrapper.call(FilePath.java:2691)
      at hudson.remoting.UserRequest.perform(UserRequest.java:121)
      at hudson.remoting.UserRequest.perform(UserRequest.java:49)
      at hudson.remoting.Request$2.run(Request.java:326)
      at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:68)
      at java.util.concurrent.FutureTask.run(FutureTask.java:262)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
      at java.lang.Thread.run(Thread.java:744)
      at ......remote call to macmini1(Native Method)
      at hudson.remoting.Channel.attachCallSiteStackTrace(Channel.java:1413)
      at hudson.remoting.UserResponse.retrieve(UserRequest.java:221)
      at hudson.remoting.Channel.call(Channel.java:778)
      at hudson.FilePath.act(FilePath.java:980)
      ... 11 more
      Caused by: javax.xml.transform.TransformerException: javax.xml.transform.TransformerException: com.sun.org.apache.xml.internal.utils.WrappedRuntimeException: Content is not allowed in prolog.
      at com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transform(TransformerImpl.java:758)
      at com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transform(TransformerImpl.java:359)
      at hudson.plugins.nunit.NUnitReportTransformer.transform(NUnitReportTransformer.java:68)
      at hudson.plugins.nunit.NUnitArchiver.invoke(NUnitArchiver.java:63)
      at hudson.plugins.nunit.NUnitArchiver.invoke(NUnitArchiver.java:26)
      at hudson.FilePath$FileCallableWrapper.call(FilePath.java:2691)
      at hudson.remoting.UserRequest.perform(UserRequest.java:121)
      at hudson.remoting.UserRequest.perform(UserRequest.java:49)
      at hudson.remoting.Request$2.run(Request.java:326)
      at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:68)
      at java.util.concurrent.FutureTask.run(FutureTask.java:262)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
      at java.lang.Thread.run(Thread.java:744)
      Caused by: javax.xml.transform.TransformerException: com.sun.org.apache.xml.internal.utils.WrappedRuntimeException: Content is not allowed in prolog.
      at com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.getDOM(TransformerImpl.java:587)
      at com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transform(TransformerImpl.java:748)
      ... 13 more
      Caused by: com.sun.org.apache.xml.internal.utils.WrappedRuntimeException: Content is not allowed in prolog.
      at com.sun.org.apache.xalan.internal.xsltc.dom.XSLTCDTMManager.getDTM(XSLTCDTMManager.java:464)
      at com.sun.org.apache.xalan.internal.xsltc.dom.XSLTCDTMManager.getDTM(XSLTCDTMManager.java:252)
      at com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.getDOM(TransformerImpl.java:565)
      ... 14 more
      Finished: FAILURE

        Attachments

          Issue Links

            Activity

            tenwit Paul Hicks added a comment -

            This is an NUnit3 results file that this plugin does not yet support. There is an XSLT file attached to issue JENKINS-32999 that can be used to transform this file to a JUnit results file.


              People

              • Assignee:
                slide_o_mix Alex Earl
                Reporter:
                mvassilev Martin Vasilev
              • Votes:
                1 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: