Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-30925

Subversion revision check consistently fails first time when using svn+ssh protocol

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: subversion-plugin
    • Environment:
      Master
      Jenkins - 1.633
      OS - Ubuntu Linux
      Java - 1.7.0_75
      SVN Plugin - 2.5.3

      Slave
      Unix slave, version 2.52
      OS - Mac OS X Yosemite 10.10.5
      Java - 1.8.0_45
    • Similar Issues:

      Description

      When attempting to build following a new commit to an SVN repository, the SVN plugin will consistently hang at "At revision x", before eventually failing with a "hudson.util.IOException2: revision check failed" caused by "org.tmatesoft.svn.core.SVNException: svn: E210004: Malformed network data".

      What's notable is that this happens consistently only on the first revision check following a commit to the repository. On every subsequent revision check (where no change is detected) the build will succeed without issue.

      There appear to be numerous previous bug reports discussing similar issues which were closed due to an inability to reproduce, but due to some unique characteristics of my environment/setup it was requested I open a new bug report for this.

      Note, I've tried numerous version of both Jenkins and the SVN plugin in an attempt to resolve this.

      One factor that's worth highlighting of possible relevancy is that we're using the svn+ssh protocol. Update: After some further tests I've identified this issue does not occur with http/s, further suggesting it may be related to the use of the svn+ssh protocol.

      Console output of failed build:

      Started by user Robbie
      Building remotely on mac-mini-slave (unity ios mac unity-ios) in workspace <redacted>
      Cleaning local Directory .
      Checking out svn+ssh:<redacted> at revision '2015-10-12T18:31:07.755 +0100'
      A         Assets
      AU        Assets/TestScene.unity
      <redacted>
       U        .
      At revision 17  // < Will hang here for some time, until I presume the build attempt times out or is cancelled
      hudson.util.IOException2: revision check failed on svn+ssh://<redacted>
      	at hudson.scm.SubversionChangeLogBuilder.buildModule(SubversionChangeLogBuilder.java:196)
      	at hudson.scm.SubversionChangeLogBuilder.run(SubversionChangeLogBuilder.java:123)
      	at hudson.scm.SubversionSCM.calcChangeLog(SubversionSCM.java:726)
      	at hudson.scm.SubversionSCM.checkout(SubversionSCM.java:861)
      	at hudson.scm.SCM.checkout(SCM.java:485)
      	at hudson.model.AbstractProject.checkout(AbstractProject.java:1277)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.defaultCheckout(AbstractBuild.java:610)
      	at jenkins.scm.SCMCheckoutStrategy.checkout(SCMCheckoutStrategy.java:86)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:532)
      	at hudson.model.Run.execute(Run.java:1741)
      	at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
      	at hudson.model.ResourceController.execute(ResourceController.java:98)
      	at hudson.model.Executor.run(Executor.java:408)
      Caused by: org.tmatesoft.svn.core.SVNException: svn: E210004: Malformed network data
      	at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:64)
      	at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:51)
      	at org.tmatesoft.svn.core.internal.io.svn.SVNReader.readChar(SVNReader.java:473)
      	at org.tmatesoft.svn.core.internal.io.svn.SVNReader.skipWhiteSpace(SVNReader.java:485)
      	at org.tmatesoft.svn.core.internal.io.svn.SVNReader.readTuple(SVNReader.java:287)
      	at org.tmatesoft.svn.core.internal.io.svn.SVNReader.parse(SVNReader.java:241)
      	at org.tmatesoft.svn.core.internal.io.svn.SVNConnection.read(SVNConnection.java:276)
      	at org.tmatesoft.svn.core.internal.io.svn.SVNConnection.authenticate(SVNConnection.java:174)
      	at org.tmatesoft.svn.core.internal.io.svn.SVNRepositoryImpl.authenticate(SVNRepositoryImpl.java:1276)
      	at org.tmatesoft.svn.core.internal.io.svn.SVNRepositoryImpl.logImpl(SVNRepositoryImpl.java:728)
      	at org.tmatesoft.svn.core.io.SVNRepository.log(SVNRepository.java:1038)
      	at org.tmatesoft.svn.core.internal.wc2.remote.SvnRemoteLog.run(SvnRemoteLog.java:181)
      	at org.tmatesoft.svn.core.internal.wc2.remote.SvnRemoteLog.run(SvnRemoteLog.java:35)
      	at org.tmatesoft.svn.core.internal.wc2.SvnOperationRunner.run(SvnOperationRunner.java:21)
      	at org.tmatesoft.svn.core.wc2.SvnOperationFactory.run(SvnOperationFactory.java:1259)
      	at org.tmatesoft.svn.core.wc2.SvnOperation.run(SvnOperation.java:294)
      	at org.tmatesoft.svn.core.wc.SVNLogClient.doLog(SVNLogClient.java:968)
      	at org.tmatesoft.svn.core.wc.SVNLogClient.doLog(SVNLogClient.java:873)
      	at hudson.scm.SubversionChangeLogBuilder.buildModule(SubversionChangeLogBuilder.java:184)
      	... 12 more
      Skipped archiving because build is not successful
      Publish artifacts to S3 Bucket Using S3 profile: Jenkins S3 Profile
      Publish artifacts to S3 Bucket Skipping publishing on S3 because build failed
      Finished: FAILURE
      

      For successful builds:

      At revision 16
      no change for svn+ssh:<redacted> since the previous build
      Piping unity Editor.log from /Users/jenkins/Library/Logs/Unity/Editor.log
      <redacted>  //(will then proceed to build successfully without issue)
      Finished: SUCCESS
      

        Attachments

          Issue Links

            Activity

            r0bbie Robbie Cargill added a comment -

            Found this post describing a "E210004: Malformed network data" error when using svn+ssh with SVNKit - https://issues.tmatesoft.com/issue/SGT-1021
            Could be relevant.

            One comment suggests upgrading to SVNKit 1.8.11 may resolve it - https://issues.tmatesoft.com/issue/SGT-1021#comment=60-7712

            r0bbie Robbie Cargill added a comment -

            No word on this?

            r0bbie Robbie Cargill added a comment -

            I believe this issue has been resolved with the release of version 2.5.5 of the SVN plugin. I note this included an upgrade to version 1.8.11 of SVNKit, as was noted as being suggested to include a fix as per my previous comment.

            Builds are now succeeding first time with svn+ssh protocol. Believe this issue may be closed.

            rodrigc Craig Rodrigues added a comment -

            Fixed with SVNKit 1.8.11 as noted by Robbie Cargill


              People

              • Assignee:
                Unassigned
                Reporter:
                r0bbie Robbie Cargill
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: