Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-3125

Hudson kills processes started within builds

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Blocker
    • Resolution: Duplicate
    • Component/s: core
    • Labels:
      None
    • Environment:
      Platform: All, OS: Linux
    • Similar Issues:

      Description

      We use Hudson to start a Tomcat application server before tests are running. The freestyle project uses
      an ant target for this with "fork=true" and "spawn=true", because we want to keep the Tomcat running
      after the build.

      Since Hudson version 1.284 it kills the tomcat-process after the build finished, even if the spawn
      option is set.

      Is there an option in Hudson available that prevents the process-killing?

      Thank you
      Timo Meinen

        Attachments

          Issue Links

            Activity

            mdonohue mdonohue added a comment -

            set the environment variable BUILD_ID to something like 'dontKillMe' in the
            process that should stay alive.

            Hudson looks for that environment variable when cleaning up stray processes.

                • This issue has been marked as a duplicate of 3105 ***

              People

              • Assignee:
                Unassigned
                Reporter:
                timomeinen timomeinen
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: