Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-31875

No working folder mapping when accessing TFS (win 10)

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Not A Defect
    • Component/s: tfs-plugin
    • Labels:
      None
    • Environment:
      Win 10, Java 8, Jenkins 1.639, Chrome
    • Similar Issues:

      Description

      1. Installed Jenkins on Windows 10
      2. Added TFS Plug-in 4.0.0 (No choice to use earlier version)
      3. Configured correct credentials to access TFS (Can access it via Team Explorer)

      Result:
      C:\Jenkins\jobs\sanityprod\workspace.
      java.lang.RuntimeException: com.microsoft.tfs.core.clients.versioncontrol.exceptions.ItemNotMappedException: There is no working folder mapping for C:\Jenkins\jobs\sanityprod\workspace.
      at hudson.plugins.tfs.model.Server.execute(Server.java:110)
      at hudson.plugins.tfs.model.Project.getFiles(Project.java:177)
      at hudson.plugins.tfs.actions.CheckoutAction.checkout(CheckoutAction.java:54)
      at hudson.plugins.tfs.TeamFoundationServerScm.checkout(TeamFoundationServerScm.java:221)
      at hudson.model.AbstractProject.checkout(AbstractProject.java:1276)
      at hudson.model.AbstractBuild$AbstractBuildExecution.defaultCheckout(AbstractBuild.java:607)
      at jenkins.scm.SCMCheckoutStrategy.checkout(SCMCheckoutStrategy.java:86)
      at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:529)
      at hudson.model.Run.execute(Run.java:1738)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
      at hudson.model.ResourceController.execute(ResourceController.java:98)
      at hudson.model.Executor.run(Executor.java:410)
      Caused by: com.microsoft.tfs.core.clients.versioncontrol.exceptions.ItemNotMappedException: There is no working folder mapping for C:\Jenkins\jobs\sanityprod\workspace.
      at com.microsoft.tfs.core.clients.versioncontrol.VersionControlClient.getLocalWorkspace(VersionControlClient.java:737)
      at com.microsoft.tfs.core.clients.versioncontrol.VersionControlClient.getWorkspace(VersionControlClient.java:2154)
      at hudson.plugins.tfs.model.MockableVersionControlClient.getWorkspace(MockableVersionControlClient.java:93)
      at hudson.plugins.tfs.commands.GetFilesToWorkFolderCommand.call(GetFilesToWorkFolderCommand.java:57)
      at hudson.plugins.tfs.commands.GetFilesToWorkFolderCommand.call(GetFilesToWorkFolderCommand.java:17)
      at hudson.remoting.LocalChannel.call(LocalChannel.java:45)
      at hudson.plugins.tfs.model.Server.execute(Server.java:106)
      ... 11 more

      note: This same setup works fine in Win 8.1 with Java 1.7. Tried deleting workspace folder and repeating. Same problem occurred

        Attachments

          Activity

          jbrantly James Brantly added a comment -

          I found that I ran into this issue when there was a period in the workspace path. Changing the period to an underscore fixed the issue right up.

          xstepl Stephen Leung added a comment -

          Thanks James, this worked! I was just about to abandon TFS for GIT. Something so simple !

          hoppe Tom Slinkyton added a comment -

          Recreating the same job resolved this issue for me

          apgray Andrew Gray added a comment -

          This issue occurred for me after I moved the job to another Folder (CloudBees Folders plugin).

          Wiping out the workspace did not resolve it.

          Turning Use Update checkbox off did.

          rayhallquist Ray Hallquist added a comment - - edited

          Turning Use Update off resolved the issue for me.
          I have spaces in the Workspace path.

          sinai Sinai Rijcov added a comment -

          Deleting "period" worked for me too. From tfsserver/version/4.0/ to tfsserver/version/

          Thank James!  

           

          brantone Brantone added a comment -

          Tried all options listed here and no luck.

          I'm wondering how many people had concurrent builds occurring on same slave agent? So far that's really consistent behaviour I've seen and suspecting that it's because there's contention over VersionControl.config on the agent.

          Steps like updating checkboxes or the workspace name could just be that it's providing enough of a gap to to allow concurrent builds to occur??

          Either way, still get this randomly  


            People

            • Assignee:
              dastahel David Staheli
              Reporter:
              xstepl Stephen Leung
            • Votes:
              3 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: