Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Duplicate
    • Component/s: robot-plugin
    • Labels:
      None
    • Environment:
      jenkins v1.642
    • Similar Issues:

      Description

      It looks like the robot framework plugin is not compatible with the changes in Jenkins v1.641.
      I'm not able to view report.html or log.html by clicking in jenkins webinterface (I get an error page, javascript disabled....). If I open the file on the machine itself there is no problem...

        Attachments

          Issue Links

            Activity

            pragmax Michael Hjembaek added a comment - - edited

            I have the exact same problem. I tried downgrading Jenkins from 1.642 -> 1.641 -> 1.640 -> 1.630 -> 1.620.

            Opening Robot Framework report failed
            {{Verify that you have JavaScript enabled in your browser.
            Make sure you are using a modern enough browser. Firefox 3.5, IE 8, or equivalent is required, newer browsers are recommended.
            Check are there messages in your browser's JavaScript error log. Please report the problem if you suspect you have encountered a bug.}}

            Looks like the log.html link is working again on 1.620. But I'am still unsure whether it was Jenkins 1.620 that did the trick or the Robot job execution. Btw. I am using Robot Framework plugin v.1.6.2.

            bollenn Nico Bollen added a comment -

            Running the job again did the trick for me at 1.640... But because of GIT problems in this version I had to go back to 1.639...

            jccheng Jeff Cheng added a comment -

            We see the same issue on Jenkins LTS 1.625.3, Robot plugin 1.6.2. Re-running our jobs to re-publish the reports/logs did not help.

            danielbeck Daniel Beck added a comment -

            Resolving as duplicate of the more popular issue JENKINS-32118 which contains a workaround/solution.


              People

              • Assignee:
                jpiironen jpiironen
                Reporter:
                bollenn Nico Bollen
              • Votes:
                4 Vote for this issue
                Watchers:
                8 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: