Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-3218

Hudson LDAP authentification is Case Sensitive

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Critical
    • Resolution: Fixed
    • Component/s: ldap-plugin
    • Labels:
      None
    • Environment:
      Platform: PC, OS: Windows 2000
    • Similar Issues:

      Description

      Hudson HudsoLDAP authentification is case sensitive. LDAP doesn't do case
      comparaison during login verification on LDAP side. But Hudson does. I enter
      following user in my project matrix table:

      "Arnold Pipo" (with all access: Administrator)

      When I try to connect with following id: "arnold pipo", I can connect but with
      only anonymous rights. If I cannot with "Arnold Pipo", I have the correct rights
      that I defined in my matrix. It seems that authentification is ok on LDAP side,
      but Hudson seems to compare "Arnold Pipo" and "arnold pipo" but it doesn't match
      (Case problem). So it considers him as anonymous user.

        Attachments

          Issue Links

            Activity

            tacianotres Taciano Tres added a comment -

            This issue is someway related to JENKINS-4354?

            williamleara williamleara added a comment -

            Similar to:
            http://issues.jenkins-ci.org/browse/JENKINS-6377

            ...which is written up vs. Active Directory.

            quick_wango Phillip Schichtel added a comment -

            I just had a problem with the same root cause: Jenkins didn't find my groups because I accidentally had one uppercase letter in my username during login.
            I think the login should either fail with wrong casing or Jenkins should just update the username from LDAP, so it continues with the correct username instead of the one with bad casing form the login.

            oleg_nenashev Oleg Nenashev added a comment -

            Fixed by JENKINS-22247 (1.566+)


              People

              • Assignee:
                Unassigned
                Reporter:
                taillant taillant
              • Votes:
                9 Vote for this issue
                Watchers:
                9 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: