Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-32515

"E200030: Index not exists: I_NODES_MOVED" while reverting working copies

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: subversion-plugin
    • Labels:
    • Environment:
      Java: 1.8.0 update 66 (build 17) 64-bit
      Jenkins: 1.644 (upgrade from 1.638)
      Subversion plug-in: 2.5.7 (upgrade from 2.5.4)
    • Similar Issues:

      Description

      After upgrading Jenkins, SVN checkouts started to fail. An exception is thrown during working copy revert:

      org.tmatesoft.svn.core.SVNException: svn: E200030: Index not exists: I_NODES_MOVED
      	at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:64)
      	at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:51)
      	at org.tmatesoft.svn.core.internal.db.SVNSqlJetDb.createSqlJetError(SVNSqlJetDb.java:195)
      	at org.tmatesoft.svn.core.internal.db.SVNSqlJetSelectStatement.openCursor(SVNSqlJetSelectStatement.java:63)
      	at org.tmatesoft.svn.core.internal.db.SVNSqlJetStatement.next(SVNSqlJetStatement.java:90)
      	at org.tmatesoft.svn.core.internal.db.SVNSqlJetSelectStatement.next(SVNSqlJetSelectStatement.java:108)
      	at org.tmatesoft.svn.core.internal.wc17.db.SvnWcDbRevert.revertRecursive(SvnWcDbRevert.java:329)
      [complete stacktrace attached]
      

      This seems to be triggered by Check-out Strategy being set to Use 'svn update' as much as possible, with 'svn revert' before update in project settings (which causes SVN revert to run as a result).

      The origin seems to be SVNKIT-582. According to the change log, the regression seems to have been introduced in 2.5.5 with SVNKit library upgraded to 1.8.11.

      Although this seems to be a known issue, I believe reporting it here can be valuable as while the original issue isn't fixed people may decide to downgrade the plug-in or plug-in developers may downgrade the library within the plug-in to the latest working version (which is...?).

        Attachments

          Activity

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: James Nord
          Path:
          bin/branding.py
          http://jenkins-ci.org/commit/packaging/362c47d7211b8db0883d6b85769269c30ea1e04c
          Log:
          [FIXED JENKINS-32515] allow specifying which variables may be blank.

          It is valid for some (and only some) variables to be blank - so allow
          these variables to be set to the empty string.

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: James Nord
          Path:
          bin/branding.py
          http://jenkins-ci.org/commit/packaging/a94c2d96e3ef3be06909dfddbc24e2b6b77e7d08
          Log:
          Merge pull request #37 from jtnord/JENKINS-32516

          [FIXED JENKINS-32515] allow specifying which variables may be blank.

          Compare: https://github.com/jenkinsci/packaging/compare/260401a800cd...a94c2d96e3ef


            People

            • Assignee:
              Unassigned
              Reporter:
              heldermagalhaes Helder Magalhães
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: