Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-32768

[pipeline multibranch] Lost configuration using Single Source

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: scm-api-plugin
    • Environment:
      Jenkins 1.609-1.642
      SCM API 1.0
      Pipeline plugin 1.13
      git-client plugin 1.19.0-1.19.2
      git plugin 2.4.0-2.4.2
    • Similar Issues:

      Description

      In a multibranch job, if you configure "Single Source" as method to checkout source, after you save, if you open configuration seems like configuration's fields were lost.

      Configuring

      Review configuration

        Attachments

          Issue Links

            Activity

            jglick Jesse Glick added a comment -

            Rarely tested, since there is not much point in using this SCM source: you would need to manually configure every branch.

            The cause is obvious from code inspection: the fields have no public getters. Should be simple to fix, and demonstrate using a functional test calling configRoundTrip using a mock Builder which takes an SCMSource field.

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Jesse Glick
            Path:
            pom.xml
            src/main/java/jenkins/scm/impl/SingleSCMSource.java
            src/main/resources/jenkins/scm/impl/SingleSCMSource/config-detail.jelly
            src/test/java/jenkins/scm/impl/SingleSCMSourceTest.java
            src/test/resources/jenkins/scm/impl/SingleSCMSourceTest/SCMSourceBuilder/config.jelly
            http://jenkins-ci.org/commit/scm-api-plugin/6e86e962f6d2e51ef8d7d8e4aabc6b8617047f5d
            Log:
            [FIXED JENKINS-32768] Round-tripping SingleSCMSource did not work.


              People

              • Assignee:
                jglick Jesse Glick
                Reporter:
                ifernandezcalvo Ivan Fernandez Calvo
              • Votes:
                3 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: