Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-32985

1.642.2-RC: Binary compatibility issue in jenkins.util.groovy.GroovyHookScript

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Blocker
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Environment:
      jenkins-1.642.2-RC
    • Similar Issues:

      Description

      It's a follow-up to JENKINS-24696, which has been fixed in https://github.com/jenkinsci/jenkins/pull/1950

      https://github.com/jenkinsci/jenkins/commit/42de07bba60bdde51ee7123ed6c65a11cddb78ae has been backported without https://github.com/jenkinsci/jenkins/commit/d3ebb8a56d06b0a816699fb2cf0c313324c71d80 .
      It causes a binary compatibility issue, because GroovyHookScript(String) constructor has been deleted. The issue appeared during the testing of the release candidate on one of our internal plugins.

        Attachments

          Issue Links

            Activity

            Hide
            olivergondza Oliver Gondža added a comment -

            Backported. Thanks!

            Show
            olivergondza Oliver Gondža added a comment - Backported. Thanks!

              People

              • Assignee:
                olivergondza Oliver Gondža
                Reporter:
                oleg_nenashev Oleg Nenashev
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: