Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: jira-plugin
    • Labels:
      None
    • Environment:
      Jenkins 1.642.2
      JIRA plugin 2.2
      JIRA 6.3.14
    • Similar Issues:

      Description

      An NPE is raised while updating JIRA issues. The comment is wrote on JIRA but the NPE makes the plugin continuously write the same comment and remember the issues for the next build.

      Error updating JIRA issues. Saving issues for next build.
      java.lang.NullPointerException
      	at hudson.plugins.jira.Updater.submitComments(Updater.java:177)
      	at hudson.plugins.jira.Updater.perform(Updater.java:128)
      	at hudson.plugins.jira.JiraIssueUpdater.perform(JiraIssueUpdater.java:64)
      	at hudson.tasks.BuildStepCompatibilityLayer.perform(BuildStepCompatibilityLayer.java:78)
      	at hudson.tasks.BuildStepMonitor$3.perform(BuildStepMonitor.java:45)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:782)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:723)
      	at hudson.maven.MavenModuleSetBuild$MavenModuleSetBuildExecution.post2(MavenModuleSetBuild.java:1047)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:668)
      	at hudson.model.Run.execute(Run.java:1763)
      	at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:531)
      	at hudson.model.ResourceController.execute(ResourceController.java:98)
      	at hudson.model.Executor.run(Executor.java:410)
      

      That seems to happen on labels.isEmpty() even if I can't figure how:

      172                 session.addComment(
      173                         issue.id,
      174                         createComment(build, useWikiStyleComments, jenkinsRootUrl, recordScmChanges, issue),
      175                         groupVisibility, roleVisibility
      176                 );
      177                 if (!labels.isEmpty()) {
      178                     session.addLabels(issue.id, labels);
      179                 }

        Attachments

          Issue Links

            Activity

            warden Radek Antoniuk added a comment -

            Duplicate of JENKINS-33293

            jcarsique Julien Carsique added a comment -

            Updated the PR with JENKINS-33293 ref

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Julien Carsique
            Path:
            src/main/java/hudson/plugins/jira/Updater.java
            http://jenkins-ci.org/commit/jira-plugin/b6ba033b5ee3ee6cfe8362573f16891b2e9d4465
            Log:
            JENKINS-33293: fix NPE on labels in Updater.submitComments()

            Duplicated by JENKINS-33551

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Radosław Antoniuk
            Path:
            src/main/java/hudson/plugins/jira/Updater.java
            http://jenkins-ci.org/commit/jira-plugin/7a58b80a3929aa3b60f13f378ece84700f4cde31
            Log:
            Merge pull request #92 from jcarsique/master

            JENKINS-33551: fix NPE on labels in Updater.submitComments()

            Compare: https://github.com/jenkinsci/jira-plugin/compare/b8980ca265eb...7a58b80a3929


              People

              • Assignee:
                Unassigned
                Reporter:
                jcarsique Julien Carsique
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: