Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-33867

Wrong link to console output when using folders and view in current url

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Cannot Reproduce
    • Component/s: extra-columns-plugin
    • Labels:
      None
    • Environment:
      Jenkins 1.655, extra-columns 1.16, Debian
    • Similar Issues:

      Description

      I recently reorganized jobs using the folders plugin from Cloudbees.

      When browsing to a job directly from the folder the console output link is correct.
      example:
      http://jenkins/job/MyFolder/job/MyJob
      gives
      <a href="/job/MyFolder/job/MyJob/1/console">

      When browsing via a view to the job then the console output link is wrong.
      example:
      http://jenkins/view/MyView/job/MyFolder/job/MyJob
      gives
      <a href="../../../../job/MyJob/1/console">

        Attachments

          Activity

          eivin Eivin Giske Skaaren added a comment -

          Might be duplicate of JENKINS-20724

          fredg Fred G added a comment -

          I can't reproduce this problem with Jenkins 2.32.2 and Extra-Columns Plugin 1.17.
          Are you sure, that you are referring to the "Last build console column" of the Extra-Columns Plugin?


            People

            • Assignee:
              fredg Fred G
              Reporter:
              eivin Eivin Giske Skaaren
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: