Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-34174

Jenkins 2.0-rc1 - Getting started hangs installing plugins

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: core
    • Labels:
    • Environment:
      jenkins 2.0-rc1
      Windows 7
      java version "1.8.0_45"
    • Similar Issues:

      Description

      Jenkins 2.0-rc1 hangs for me when installing plugins. I started it with a new jenkins home:

      set JENKINS_HOME=c:\j2
      java -jar jenkins-2.0-rc1.war
      Copy admin password into localhost:8080
      Install suggested plugins

      Some plugins install, others just sit and spin. I have left if for over an hour.

      There is an exception in the console:

      java.lang.InstantiationException: java.lang.NoClassDefFoundError: com/cloudbees/hudson/plugins/folder/AbstractFolderPropertyDescriptor
              at net.java.sezpoz.IndexItem.element(IndexItem.java:146)
              at hudson.ExtensionFinder$Sezpoz._find(ExtensionFinder.java:623)
              at hudson.ExtensionFinder$Sezpoz.access$800(ExtensionFinder.java:550)
              at hudson.ExtensionFinder$Sezpoz$1.find(ExtensionFinder.java:594)
              at hudson.ExtensionFinder$GuiceFinder.refresh(ExtensionFinder.java:329)
              at jenkins.model.Jenkins.refreshExtensions(Jenkins.java:2383)
              at hudson.PluginManager.dynamicLoad(PluginManager.java:691)
              at hudson.model.UpdateCenter$InstallationJob._run(UpdateCenter.java:1670)
              at hudson.model.UpdateCenter$DownloadJob.run(UpdateCenter.java:1452)
              at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
              at java.util.concurrent.FutureTask.run(Unknown Source)
              at hudson.remoting.AtmostOneThreadExecutor$Worker.run(AtmostOneThreadExecutor.java:110)
              at java.lang.Thread.run(Unknown Source)
      Caused by: java.lang.NoClassDefFoundError: com/cloudbees/hudson/plugins/folder/A bstractFolderPropertyDescriptor
              at java.lang.ClassLoader.defineClass1(Native Method)
              at java.lang.ClassLoader.defineClass(Unknown Source)
              at jenkins.util.AntClassLoader.defineClassFromData(AntClassLoader.java:1139)
              at hudson.ClassicPluginStrategy$AntClassLoader2.defineClassFromData(ClassicPluginStrategy.java:895)
              at jenkins.util.AntClassLoader.getClassFromStream(AntClassLoader.java:1310)
              at jenkins.util.AntClassLoader.findClassInComponents(AntClassLoader.java:1366)
              at jenkins.util.AntClassLoader.findClass(AntClassLoader.java:1326)
              at sun.reflect.GeneratedMethodAccessor12.invoke(Unknown Source)
              at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
              at java.lang.reflect.Method.invoke(Unknown Source)
              at jenkins.ClassLoaderReflectionToolkit.invoke(ClassLoaderReflectionToolkit.java:44)
              at jenkins.ClassLoaderReflectionToolkit._findClass(ClassLoaderReflectionToolkit.java:86)
              at hudson.PluginManager$UberClassLoader.findClass(PluginManager.java:1548)
              at java.lang.ClassLoader.loadClass(Unknown Source)
              at java.lang.ClassLoader.loadClass(Unknown Source)
              at net.java.sezpoz.IndexItem.element(IndexItem.java:134)
              ... 12 more
      Caused by: java.lang.ClassNotFoundException: com.cloudbees.hudson.plugins.folder.AbstractFolderPropertyDescriptor
              at jenkins.util.AntClassLoader.findClassInComponents(AntClassLoader.java:1376)
              at jenkins.util.AntClassLoader.findClass(AntClassLoader.java:1326)
              at jenkins.util.AntClassLoader.loadClass(AntClassLoader.java:1079)
              at java.lang.ClassLoader.loadClass(Unknown Source)
              ... 28 more
      

        Attachments

        1. GettingStartedHang.png
          82 kB
          Russell Gallop
        2. threadDump.txt
          32 kB
          Russell Gallop
        3. threadDump2.txt
          32 kB
          Russell Gallop

          Issue Links

            Activity

            kzantow Keith Zantow added a comment -

            Sam Van Oort yes, a failed plugin install for any reason should show up as an error. In addition to the 'retry' option from another ticket, I think the experience here should be as good as can be expected when downloading plugins is failing.

            svanoort Sam Van Oort added a comment -

            Yeah, if there's any way we can simply use the logic from normal plugin installation, I think that's a reasonable step, if it saves effort.

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: kzantow
            Path:
            core/src/main/java/hudson/PluginManager.java
            core/src/main/java/hudson/model/UpdateCenter.java
            core/src/main/resources/jenkins/install/pluginSetupWizard.properties
            war/src/main/js/api/pluginManager.js
            war/src/main/js/pluginSetupWizardGui.js
            war/src/main/js/templates/successPanel.hbs
            http://jenkins-ci.org/commit/jenkins/6974d2b7593e3eef3a7fd28117b58382c3368189
            Log:
            JENKINS-33244 / JENKINS-34174 - retry for failed plugins & specify
            download timeout

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: kzantow
            Path:
            core/src/main/java/hudson/PluginManager.java
            core/src/main/resources/jenkins/install/pluginSetupWizard.properties
            war/src/main/js/pluginSetupWizardGui.js
            war/src/main/js/templates/pluginSelectionPanel.hbs
            war/src/main/js/templates/welcomePanel.hbs
            war/src/main/less/pluginSetupWizard.less
            http://jenkins-ci.org/commit/jenkins/e612f4163a0e1acedfed9baed6e79cf2bad6fabe
            Log:
            Merge remote-tracking branch 'primary/master' into
            JENKINS-34174-plugin-download-timeout

            1. Conflicts:
            2. core/src/main/resources/jenkins/install/pluginSetupWizard.properties
            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Daniel Beck
            Path:
            core/src/main/java/hudson/PluginManager.java
            core/src/main/java/hudson/model/UpdateCenter.java
            core/src/main/resources/jenkins/install/pluginSetupWizard.properties
            war/src/main/js/api/pluginManager.js
            war/src/main/js/pluginSetupWizardGui.js
            war/src/main/js/templates/successPanel.hbs
            http://jenkins-ci.org/commit/jenkins/8a19e8ae3d82602bf36ac5624056cae2e6950e25
            Log:
            Merge pull request #2282 from kzantow/JENKINS-34174-plugin-download-timeout

            JENKINS-33244 better handling of failed plugins during setup wizard

            Compare: https://github.com/jenkinsci/jenkins/compare/a4b070bd7357...8a19e8ae3d82


              People

              • Assignee:
                kzantow Keith Zantow
                Reporter:
                rg Russell Gallop
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: