Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-34697

docker-build-step not working with question mark in password

    Details

    • Type: Bug
    • Status: Open (View Workflow)
    • Priority: Minor
    • Resolution: Unresolved
    • Labels:
      None
    • Environment:
      Jenkins ver. 1.658
      Docker Commons Plugin 1.3.1
      Credentials Plugin 1.27
      docker-build-step 1.34
      (for reference: CloudBees Docker Build and Publish plugin 1.2.1)
    • Similar Issues:

      Description

      Using a credential with a question mark in the password is causing the docker-build-step plugin to fail when accessing a private repository in the docker hub.

      In the docker log I can see the following message when trying to run a docker-build-step command (output from a docker pull step):
      level=error msg="Attempting next endpoint for pull after error: unauthorized: authentication required"

      As soon as I remove the question mark (and replace it by any other character including #) the docker pull is working as expected.

      The credentials themselves are properly setup - I am able to execute the build and publish step from the CloudBees plugin - with or without the question mark in the password.

        Attachments

          Activity

          There are no comments yet on this issue.

            People

            • Assignee:
              vjuranek vjuranek
              Reporter:
              sebastianhutter Sebastian Hutter
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated: