Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-3501

File operations failing on remote host

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Incomplete
    • Component/s: ssh-slaves-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: Linux

      Description

      Using SSH slaves, I cannot use the Violations plugin nor the JUnit test result
      feature, both fail with ambiguous file system operation failures.

      Violations:
      ======================================================
      FATAL: remote file operation failed
      hudson.util.IOException2: remote file operation failed
      at hudson.FilePath.act(FilePath.java:548)
      at hudson.plugins.violations.ViolationsPublisher.perform
      (ViolationsPublisher.java:77)
      at hudson.tasks.BuildStepCompatibilityLayer.perform
      (BuildStepCompatibilityLayer.java:56)
      at hudson.model.AbstractBuild$AbstractRunner.performAllBuildStep
      (AbstractBuild.java:372)
      at hudson.model.AbstractBuild$AbstractRunner.performAllBuildStep
      (AbstractBuild.java:360)
      at hudson.model.Build$RunnerImpl.post2(Build.java:183)
      at hudson.model.AbstractBuild$AbstractRunner.post
      (AbstractBuild.java:345)
      at hudson.model.Run.run(Run.java:943)
      at hudson.model.Build.run(Build.java:112)
      at hudson.model.ResourceController.execute(ResourceController.java:93)
      at hudson.model.Executor.run(Executor.java:119)
      Caused by: java.io.IOException: Remote call failed
      at hudson.remoting.Channel.call(Channel.java:490)
      at hudson.FilePath.act(FilePath.java:545)
      ... 10 more
      Caused by: java.lang.NoClassDefFoundError: hudson/maven/MavenReporterDescriptor
      at java.lang.ClassLoader.defineClass1(Native Method)
      at java.lang.ClassLoader.defineClass(ClassLoader.java:637)
      at java.lang.ClassLoader.defineClass(ClassLoader.java:482)
      at hudson.remoting.RemoteClassLoader.findClass
      (RemoteClassLoader.java:100)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:323)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:268)
      at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:336)
      at hudson.plugins.violations.ViolationsCollector.invoke
      (ViolationsCollector.java:98)
      at hudson.plugins.violations.ViolationsCollector.invoke
      (ViolationsCollector.java:27)
      at hudson.FilePath$FileCallableWrapper.call(FilePath.java:1517)
      at hudson.remoting.UserRequest.perform(UserRequest.java:97)
      at hudson.remoting.UserRequest.perform(UserRequest.java:46)
      at hudson.remoting.Request$2.run(Request.java:236)
      at java.util.concurrent.Executors$RunnableAdapter.call
      (Executors.java:471)
      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
      at java.util.concurrent.FutureTask.run(FutureTask.java:166)
      at java.util.concurrent.ThreadPoolExecutor.runWorker
      (ThreadPoolExecutor.java:1110)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run
      (ThreadPoolExecutor.java:603)
      at java.lang.Thread.run(Thread.java:636)
      Caused by: java.lang.ClassNotFoundException:
      hudson.maven.MavenReporterDescriptor
      at hudson.remoting.RemoteClassLoader$ClassLoaderProxy.fetch
      (RemoteClassLoader.java:264)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke
      (NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke
      (DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at hudson.remoting.RemoteInvocationHandler$RPCRequest.perform
      (RemoteInvocationHandler.java:263)
      at hudson.remoting.Request$2.run(Request.java:236)
      at java.util.concurrent.Executors$RunnableAdapter.call
      (Executors.java:441)
      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
      at java.util.concurrent.FutureTask.run(FutureTask.java:138)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask
      (ThreadPoolExecutor.java:885)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run
      (ThreadPoolExecutor.java:907)
      at java.lang.Thread.run(Thread.java:619)

        Activity

        rtyler R. Tyler Croy added a comment -

        Stupid issue tracker double-posting.


          People

          • Assignee:
            stephenconnolly stephenconnolly
            Reporter:
            rtyler R. Tyler Croy
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: