Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-35023

Slave configuration page time-outs

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Critical
    • Resolution: Cannot Reproduce
    • Component/s: core
    • Environment:
      Jenkins 2.6 running on Ubuntu 12.04.5
      OpenJDK Java 1.7.0_101
    • Similar Issues:

      Description

      Trying to open a slave configuration page Jenkins Java process starts to consume 100% CPU and no respond is received in 3.5 HOURS (curl from the server running Jenkins).

      The URL causing the issue:

      https://<jenkins_server_address>/jenkins/computer/<slave_name>/configure

        Attachments

          Issue Links

            Activity

            thorbenegberts Thorben Egberts added a comment - - edited

            Same here. Currently I cannot add new nodes at "/computer/new". It says 'Site is loading…", but nothing happens. So… coffee time for me

            abychko Alexey Bychko added a comment - - edited

            tested on many linux distributions, jenkins/java versions. the result is the same, looks like futex() issue:

            [pid  2388] futex(0x7f709c150f54, FUTEX_WAIT_BITSET_PRIVATE, 1, {942, 33550318}, ffffffff) = -1 ETIMEDOUT (Connection timed out)
            [pid  2388] futex(0x7f709c150f28, FUTEX_WAKE_PRIVATE, 1) = 0
            [pid  2388] clock_gettime(CLOCK_MONOTONIC, {942, 38232557}) = 0
            [pid  2388] clock_gettime(CLOCK_MONOTONIC, {942, 38272076}) = 0
            [pid  2388] clock_gettime(CLOCK_MONOTONIC, {942, 38297637}) = 0
            [pid  2388] clock_gettime(CLOCK_MONOTONIC, {942, 38315636}) = 0
            [pid  2388] futex(0x7f709c150f54, FUTEX_WAIT_BITSET_PRIVATE, 1, {942, 88315636}, ffffffff <unfinished ...>
            [pid  2397] <... restart_syscall resumed> ) = -1 ETIMEDOUT (Connection timed out)
            
            danielbeck Daniel Beck added a comment -

            According to JENKINS-35050 an update of the Credentials Plugin resolves this?

            abychko Alexey Bychko added a comment -

            yes, it does

            danielbeck Daniel Beck added a comment -

            Possible bug or core interaction in Credentials Plugin, upgrading that fixes this.


              People

              • Assignee:
                Unassigned
                Reporter:
                freol Vlad Frolov
              • Votes:
                4 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: