Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-35197

unable to use jenkins-cli: java.io.StreamCorruptedException

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Duplicate
    • Component/s: cli
    • Labels:
    • Environment:
      debian/jessie Jenkins 2.06,
      CentOS 7 Jenkins 2.19
    • Similar Issues:

      Description

      using a brand new install on a new server
      executed
      java -jar /opt/jenkins-cli.jar -s http://localhost:8080 help{

      Got the following stack trace:
      SEVERE: I/O error in channel Chunked connection to http://localhost:8080/cli
      java.io.StreamCorruptedException: invalid stream header: 0A0A0A0A
      at java.io.ObjectInputStream.readStreamHeader(ObjectInputStream.java:807)
      at java.io.ObjectInputStream.<init>(ObjectInputStream.java:302)
      at hudson.remoting.ObjectInputStreamEx.<init>(ObjectInputStreamEx.java:48)
      at hudson.remoting.AbstractSynchronousByteArrayCommandTransport.read(AbstractSynchronousByteArrayCommandTransport.java:34)
      at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:48)

      hudson.remoting.RequestAbortedException: java.io.StreamCorruptedException: invalid stream header: 0A0A0A0A
      at hudson.remoting.Request.abort(Request.java:303)
      at hudson.remoting.Channel.terminate(Channel.java:847)
      at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:69)
      at ......remote call to Chunked connection to http://localhost:8080/cli(Native Method)
      at hudson.remoting.Channel.attachCallSiteStackTrace(Channel.java:1416)
      at hudson.remoting.Request.call(Request.java:172)
      at hudson.remoting.Channel.call(Channel.java:780)
      at hudson.remoting.RemoteInvocationHandler.invoke(RemoteInvocationHandler.java:249)
      at hudson.remoting.$Proxy1.waitForProperty(Unknown Source)
      at hudson.remoting.Channel.waitForRemoteProperty(Channel.java:1258)
      at hudson.cli.CLI.<init>(CLI.java:141)
      at hudson.cli.CLIConnectionFactory.connect(CLIConnectionFactory.java:72)
      at hudson.cli.CLI._main(CLI.java:473)
      at hudson.cli.CLI.main(CLI.java:384)
      Caused by: java.io.StreamCorruptedException: invalid stream header: 0A0A0A0A
      at java.io.ObjectInputStream.readStreamHeader(ObjectInputStream.java:807)
      at java.io.ObjectInputStream.<init>(ObjectInputStream.java:302)
      at hudson.remoting.ObjectInputStreamEx.<init>(ObjectInputStreamEx.java:48)
      at hudson.remoting.AbstractSynchronousByteArrayCommandTransport.read(AbstractSynchronousByteArrayCommandTransport.java:34)
      at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:48)

      Found an old issue that suggested making the following change that worked for me. Not sure if this is a bug or a configuration issue, but thought it would be helpful to anyone else who runs into this problem.

      I tried the follow solution that worked:
      edit /etc/default/jenkins and changed

      JAVA_ARGS="-Djava.awt.headless=true"

      to

      JAVA_ARGS="-Djava.awt.headless=true -Dhudson.diyChunking=false"

      and then restarted jenkins (sudo service jenkins restart)
      PS. Love jenkins. thank you!

        Attachments

          Issue Links

            Activity

            pjohnsonic509 Phil Johnson added a comment -

            I believe this issue is still open ?!?

            We are experiencing it with: Jenkins ver. 2.19
            Java "1.7.0_111"

            Love Jenkins also - this should be addressed though, either through much better documentation or a fix.

            oleg_nenashev Oleg Nenashev added a comment -

            Closing as a duplicate of JENKINS-23232. It is still actual by the way


              People

              • Assignee:
                Unassigned
                Reporter:
                atulhm Atul Patel
              • Votes:
                1 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: