Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-36337

Git plugin can't auto get the changes from gitlab when use http://IP/xx.git

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      Jenkins can't use the Git plugin auto get the changes from gitlab( http://IP/xx.git) then trigger new build.
      Now we need trigger the job by hand.
      Does the git plugin didn't support the gitlab use http:// ? Or some other configuration can slove this problem.

        Attachments

        1. 1.jpg
          1.jpg
          97 kB
        2. 2.jpg
          2.jpg
          14 kB

          Activity

          Hide
          markewaite Mark Waite added a comment -

          The version of command line git you're using is too old for https credential support. You can either enable and use the JGit (pure java) implementation, or you can install a more recent version of command line git.

          That output typically comes from a CentOS 5 or CentOS 6 machine where the default git version is too old to support full credentials.

          Show
          markewaite Mark Waite added a comment - The version of command line git you're using is too old for https credential support. You can either enable and use the JGit (pure java) implementation, or you can install a more recent version of command line git. That output typically comes from a CentOS 5 or CentOS 6 machine where the default git version is too old to support full credentials.
          Hide
          rexuekonglong ying zhang added a comment -

          Sorry forgot give the git version. I upgrade the git version to 1.8.4 to get the code from gitlab(8.8.7), then find the problem.

          Show
          rexuekonglong ying zhang added a comment - Sorry forgot give the git version. I upgrade the git version to 1.8.4 to get the code from gitlab(8.8.7), then find the problem.
          Hide
          markewaite Mark Waite added a comment -

          I'm not sure I understand the meaning of your response. Can you clarify for me?

          My CentOS 7 machine (updated with latest operating system updates through "yum update") includes git 1.8.3.1 and it supports the "git config --local credential.username MarkEWaite" command.

          My CentOS 6 machine (updated with latest operating system updates through "yum update") includes git 1.7.1. It does not support the "git config --local credential.username MarkEWaite" command.

          When you said

          I upgrade the git version to 1.8.4 to get the code from gitlab(8.8.7), then find the problem

          , did you mean that the solution to the problem you found was to upgrade git to 1.8.4, or did you mean that upgrading to git 1.8.4 did not solve the problem you were seeing?

          Show
          markewaite Mark Waite added a comment - I'm not sure I understand the meaning of your response. Can you clarify for me? My CentOS 7 machine (updated with latest operating system updates through "yum update") includes git 1.8.3.1 and it supports the "git config --local credential.username MarkEWaite" command. My CentOS 6 machine (updated with latest operating system updates through "yum update") includes git 1.7.1. It does not support the "git config --local credential.username MarkEWaite" command. When you said I upgrade the git version to 1.8.4 to get the code from gitlab(8.8.7), then find the problem , did you mean that the solution to the problem you found was to upgrade git to 1.8.4, or did you mean that upgrading to git 1.8.4 did not solve the problem you were seeing?
          Hide
          rexuekonglong ying zhang added a comment -

          I use the rpm -ivh git-1.8.4-1.ep.x86_64.rpm update the git on my Centos 6.5 both jenkins master and build slave.

          Show
          rexuekonglong ying zhang added a comment - I use the rpm -ivh git-1.8.4-1.ep.x86_64.rpm update the git on my Centos 6.5 both jenkins master and build slave.
          Hide
          rexuekonglong ying zhang added a comment -

          I found the solution, both the jenkins master and the code build server (slave) had to update the git version.

          Show
          rexuekonglong ying zhang added a comment - I found the solution, both the jenkins master and the code build server (slave) had to update the git version.
          Hide
          rexuekonglong ying zhang added a comment -

          Now I got that was no a bug,.

          T he build slave  server  you want to get code , just install the Git and  ssh key

          Show
          rexuekonglong ying zhang added a comment - Now I got that was no a bug,. T he build slave  server  you want to get code , just install the Git and  ssh key

            People

            • Assignee:
              rexuekonglong ying zhang
              Reporter:
              rexuekonglong ying zhang
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: