Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-36817

False warnings: Failed to copy 2016-07-20 02 to .../builds/.../workspace-files/4581fd88.tmp

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: warnings-plugin
    • Labels:
      None
    • Environment:
      Jenkins ver. 2.10
      Warnings plugin 4.56
    • Similar Issues:

      Description

      There are multiple false warnings appear/disappear in every build, hiding real warnings and test issues of every job.

      Job configured to scan a single log file in workspace with Clang (LLVM based) parser. There are no records like this in the file. There are no folders like this in the workspace. Built at master.

      Warning example.

      The warning itself is shown at line 15 with text '11 database corruption at line 51393 of':

      Content of file

      01 Copying the source file '2016-07-20 02' from the workspace to the build folder '4581fd88.tmp' on the Jenkins master failed.
      02 Seems that the path is relative, however an absolute path is required when copying the sources.
      03 Is the file '2016-07-20 02' contained more than once in your workspace?
      04 Is the file '2016-07-20 02' a valid filename?
      05 If you are building on a slave: please check if the file is accessible under '$JENKINS_HOME/[job-name]/2016-07-20 02'
      06 If you are building on the master: please check if the file is accessible under '$JENKINS_HOME/[job-name]/workspace/2016-07-20 02'
      07 java.io.IOException: Failed to copy 2016-07-20 02 to /jenkins/builds/App1UnitTests/2377/workspace-files/4581fd88.tmp
      08   at hudson.FilePath.copyTo(FilePath.java:2018)
      09   at hudson.plugins.analysis.util.Files.copyFilesWithAnnotationsToBuildFolder(Files.java:80)
      10   at hudson.plugins.analysis.core.HealthAwareRecorder.copyFilesWithAnnotationsToBuildFolder(HealthAwareRecorder.java:333)
      11   at hudson.plugins.analysis.core.HealthAwarePublisher.perform(HealthAwarePublisher.java:89)
      12   at hudson.plugins.analysis.core.HealthAwareRecorder.perform(HealthAwareRecorder.java:280)
      13   at hudson.tasks.BuildStepCompatibilityLayer.perform(BuildStepCompatibilityLayer.java:78)
      14   at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)
      15   at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:779)
      16   at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:720)
      17   at hudson.model.Build$BuildExecution.post2(Build.java:185)
      18   at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:665)
      19   at hudson.model.Run.execute(Run.java:1745)
      20   at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
      21   at hudson.model.ResourceController.execute(ResourceController.java:98)
      22   at hudson.model.Executor.run(Executor.java:410)
      23 Caused by: java.io.FileNotFoundException: 2016-07-20 02 (No such file or directory)
      24   at java.io.FileInputStream.open0(Native Method)
      25   at java.io.FileInputStream.open(FileInputStream.java:195)
      26   at java.io.FileInputStream.<init>(FileInputStream.java:138)
      27   at hudson.FilePath$41.invoke(FilePath.java:2044)
      28   at hudson.FilePath$41.invoke(FilePath.java:2039)
      29   at hudson.FilePath.act(FilePath.java:1018)
      30   at hudson.FilePath.act(FilePath.java:996)
      31   at hudson.FilePath.copyTo(FilePath.java:2039)
      32   at hudson.FilePath.copyTo(FilePath.java:2013)
      33   ... 14 more
      
      

        Attachments

          Activity

          drulli Ulli Hafner added a comment -

          Can you please attach the part of the console log that results in this warning?

          vorobievalex Alexander Vorobiev added a comment -

          The problem is that parsed log file contains no records related to these warnings.
          No related lines can be found in the jenkins system log either.

          These are some internal jenkins logs and internal jenkins tmp file that name might be constructed here:
          https://github.com/jenkinsci/analysis-core-plugin/blob/master/src/main/java/hudson/plugins/analysis/util/model/AbstractAnnotation.java#L366

          drulli Ulli Hafner added a comment -

          Sorry, I do not follow.

          Just to clarify: The content of the file above is an exception trace from my plugin, it helps to identify the problem. What I would like to know: why is there a warning with a broken file-name, so I need to find the cause of this.

          You wrote above:

          Warning example.
          The warning itself is shown at line 15 with text '11 database corruption at line 51393 of':

          Can you show the full properties of the warning with this text? How does the log file look that contains this message (just that line is interesting).

          vorobievalex Alexander Vorobiev added a comment -

          Ah, got it now. The text '11 database corruption at line 51393 of' must have existed in the log parsed, while stack trace is plugin internal stuff.

          I cannot reproduce the same issue now, but I have several equal cases with other strings. Here are the examples:
          2017-01-09 23:58:38.845 TheApp[23132:1512765431] void dbErrorLogCallback(...[Line 346] SQL error: 23 misuse at line 112343 of [c78c5a7786]
          2017-01-09 23:57:56.598 TheApp[22354:151245512] void dbErrorLogCallback(...[Line 326] SQL error: 232 statement aborts at 12: [select a.id, a.zid, a.user_id
          2017-01-09 23:58:38.943 TheApp[26457:151457651] void dbErrorLogCallback(...[Line 324] SQL error: 1 no such table: main.bin_fr_st

          These are the app output itself, appeared during UT execution. These lines lead to the following warnings with traces similar to above:
          23 misuse at line 112343 of [c78c5a7786]
          232 statement aborts at 12: [select a.id, a.zid, a.user_id
          1 no such table: main.bin_fr_st

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Ulli Hafner
          Path:
          src/main/java/hudson/plugins/warnings/parser/ClangParser.java
          src/test/java/hudson/plugins/warnings/parser/ClangParserTest.java
          src/test/resources/hudson/plugins/warnings/parser/issue36817.txt
          warnings.iml
          http://jenkins-ci.org/commit/warnings-plugin/b49d2b85a32f6b62a218386a2c922d48332973ed
          Log:
          [FIXED JENKINS-36817] Fixed false positives.


            People

            • Assignee:
              drulli Ulli Hafner
              Reporter:
              vorobievalex Alexander Vorobiev
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: