Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-37062

stapler implements Servlet API 2.5 yet Jenkins requires 3.1

    Details

    • Similar Issues:

      Description

      Stapler implements only the servlet 2.5 API - yet Jenkins uses 3.1

      If you attempt to use parts of the 3.1 API on a StaplerRequest or StaplerResponse then wierd/bad things could happen depending on what you get underneath..

      I have not observed any issues yet - but if you get a org.kohsuke.stapler.StaplerResponseWrapper rather than a org.kohsuke.stapler.ResponseImpl then things are liable to blow up. the same probably applies to StaplerRequest sub classes.

        Attachments

          Activity

            People

            • Assignee:
              teilo James Nord
              Reporter:
              teilo James Nord
            • Votes:
              1 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: