Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-37257

Buildqueue shows inconsistent entries from time to time

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Component/s: core
    • Labels:
    • Environment:
      Jenkins 1.625.3
    • Similar Issues:

      Description

      Every 3-4 ajax refreshes, the build queue shows fewer jobs (right now it goes from showing 88 builds, to only 3 builds). Problem is since upgrade from 1.523.

      It's interesting to note that the bad requests (the ones that received a response in under 50 ms in the pic below) show

      collapseBuild Queue
      No builds in the queue.
      

      and not the 3 jobs you can see in the interface.

        Attachments

          Activity

          danielbeck Daniel Beck added a comment -

          Problem is since upgrade from 1.523.

          ~100 release in between? That doesn't exactly narrow it down…

          oleg_nenashev Oleg Nenashev added a comment -

          Not sure what to do with that. Starting from 1.609.x the queue API has eventual consistency by design due to the snapshot engine. Since the reported version is 1.625.x, I propose to close it as "Not a Defect"

          Daniel Beck do you agree?

          danielbeck Daniel Beck added a comment -

          Looks more like 'Cannot Reproduce'. Because we can't, and don't have enough information to investigate further. Anyone reopening (or filing a new bug) should make sure to gather as much information about the environment and the circumstances for this issue to occur as possible.


            People

            • Assignee:
              Unassigned
              Reporter:
              silviump Silviu Marchis
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: