Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-37642

SVN Checkout with external fails only after new commit

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Blocker
    • Resolution: Duplicate
    • Component/s: subversion-plugin
    • Labels:
      None
    • Environment:
      Jenkins 2.7.2 (recently updated from 1.6)
      subversion-plugin 2.6
    • Similar Issues:

      Description

      Jenkins is configured to poll for new changes in the subversion repository. The repository contains externals (with correct credentials and realm).

      The jobs fails with the message below after a commit to the repository. If the build is triggered manually afterwards everything works fine. The address marked "svn.project" is repository while "svn.external" is the included external.

      It appears that the checkout itself succeeded but the parsing of additional data from the external fails.

      A (...)
      A (...)
      A (...)
      U (...)

      At revision 745 --> this is from svn.external

      At revision 2178 --> this is from svn.project

      No changes for https://svn.project since the previous build
      [Pipeline] }
      [Pipeline] // node
      [Pipeline] End of Pipeline
      hudson.util.IOException2: revision check failed on https://svn.external
      at hudson.scm.SubversionChangeLogBuilder.buildModule(SubversionChangeLogBuilder.java:208)
      at hudson.scm.SubversionChangeLogBuilder.run(SubversionChangeLogBuilder.java:138)
      at hudson.scm.SubversionSCM.calcChangeLog(SubversionSCM.java:725)
      at hudson.scm.SubversionSCM.checkout(SubversionSCM.java:860)
      at org.jenkinsci.plugins.workflow.steps.scm.SCMStep.checkout(SCMStep.java:109)
      at org.jenkinsci.plugins.workflow.steps.scm.SCMStep$StepExecutionImpl.run(SCMStep.java:83)
      at org.jenkinsci.plugins.workflow.steps.scm.SCMStep$StepExecutionImpl.run(SCMStep.java:73)
      at org.jenkinsci.plugins.workflow.steps.AbstractSynchronousNonBlockingStepExecution$1$1.call(AbstractSynchronousNonBlockingStepExecution.java:52)
      at hudson.security.ACL.impersonate(ACL.java:213)
      at org.jenkinsci.plugins.workflow.steps.AbstractSynchronousNonBlockingStepExecution$1.run(AbstractSynchronousNonBlockingStepExecution.java:49)
      at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
      at java.util.concurrent.FutureTask.run(FutureTask.java:266)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
      at java.lang.Thread.run(Thread.java:745)
      Caused by: org.tmatesoft.svn.core.SVNException: svn: E130003: Parser configuration problem: namespace reporting is not enabled
      at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:64)
      at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:51)
      at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:793)
      at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:398)
      at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:386)
      at org.tmatesoft.svn.core.internal.io.dav.DAVConnection.performHttpRequest(DAVConnection.java:863)
      at org.tmatesoft.svn.core.internal.io.dav.DAVConnection.doReport(DAVConnection.java:360)
      at org.tmatesoft.svn.core.internal.io.dav.DAVConnection.doReport(DAVConnection.java:350)
      at org.tmatesoft.svn.core.internal.io.dav.DAVRepository.logImpl(DAVRepository.java:1024)
      at org.tmatesoft.svn.core.io.SVNRepository.log(SVNRepository.java:1038)
      at org.tmatesoft.svn.core.internal.wc2.remote.SvnRemoteLog.run(SvnRemoteLog.java:181)
      at org.tmatesoft.svn.core.internal.wc2.remote.SvnRemoteLog.run(SvnRemoteLog.java:35)
      at org.tmatesoft.svn.core.internal.wc2.SvnOperationRunner.run(SvnOperationRunner.java:21)
      at org.tmatesoft.svn.core.wc2.SvnOperationFactory.run(SvnOperationFactory.java:1235)
      at org.tmatesoft.svn.core.wc2.SvnOperation.run(SvnOperation.java:294)
      at org.tmatesoft.svn.core.wc.SVNLogClient.doLog(SVNLogClient.java:968)
      at org.tmatesoft.svn.core.wc.SVNLogClient.doLog(SVNLogClient.java:873)
      at hudson.scm.SubversionChangeLogBuilder.buildModule(SubversionChangeLogBuilder.java:194)
      ... 14 more
      Finished: FAILURE

        Attachments

          Issue Links

            Activity

            seanscoggins Sean Scoggins added a comment -

            Same problem here, using multibranch pipeline projects (freestyle projects do not seem to be affected). I have tried creating new projects (same Jenkinsfile) and get the same error. Have tried clearing cached credentials on master and slaves, same problem. Stack trace is identical to the original report. Builds consistently fail whenever there are changes in the repo. No changes in the repo leads to successful builds. All projects were building prior, so I am assuming this was introduced with a recent update of Jenkins or the plugin. Happy to provide more info or try experiments. Jenkins 2.18, Pipeline 2.2, Pipeline SCM 2.2, Subversion 2.6.

            seanscoggins Sean Scoggins added a comment -

            Forgot to mention that I have no externals in my svn repo but see the exact same stack trace.

            carbonfish Peng Yu added a comment -

            Same issue here when upgrade Pipeline: Groovy plugin 2.12 . A workaround is to downgrade Pipeline: Groovy plugin to 2.11.

            seanscoggins Sean Scoggins added a comment -

            Downgrading Jenkins to 2.17 from 2.18 seems to have resolved this for me. I have Jenkins 2.17, Pipeline: Groovy 2.12, Subversion 2.6, Pipeline: SCM 2.2.

            jglick Jesse Glick added a comment -

            Maybe dupe of JENKINS-32167?


              People

              • Assignee:
                Unassigned
                Reporter:
                fabian_greif Fabian Greif
              • Votes:
                8 Vote for this issue
                Watchers:
                12 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: