Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-38635

NodeLabelParameter empty on rebuild of job initiated by Startup Trigger

    Details

    • Similar Issues:

      Description

      When rebuilding a job that was initiated by startup-trigger the Node Label Parameter is apparently not filled correctly. The job goes into queue with the message "pending - There are no nodes with the label ''"

      I haven't been able to verify this behavior in other scenarios, so it could be a problem with the Startup Trigger plugin, maybe something to do with the way it schedules the job?

        Attachments

          Activity

          Hide
          orgads Orgad Shaneh added a comment -

          I have this issue too, but with manual trigger.

          That is, I trigger a job manually with a label parameter, but rebuild doesn't preserve this parameter (which is mandatory in my case). All the other params are recovered correctly.

          Show
          orgads Orgad Shaneh added a comment - I have this issue too, but with manual trigger. That is, I trigger a job manually with a label parameter, but rebuild doesn't preserve this parameter (which is mandatory in my case). All the other params are recovered correctly.
          Hide
          orgads Orgad Shaneh added a comment -

          And now I see there's an open PR for this: https://github.com/jenkinsci/rebuild-plugin/pull/30

          Can you please merge it?

          Show
          orgads Orgad Shaneh added a comment - And now I see there's an open PR for this: https://github.com/jenkinsci/rebuild-plugin/pull/30 Can you please merge it?
          Hide
          nealmac01 Neal Macdonald added a comment - - edited

          Same fail here from a 'Rebuild Last' click - Node parameter is blank. I'd be grateful if we can get rebuild-plugin rebuilt since 'Rebuild' with previous parameters is so useful

          Show
          nealmac01 Neal Macdonald added a comment - - edited Same fail here from a 'Rebuild Last' click - Node parameter is blank. I'd be grateful if we can get rebuild-plugin rebuilt since 'Rebuild' with previous parameters is so useful
          Hide
          ejpenney Emory Penney added a comment -

          I've had success with this: https://github.com/jenkinsci/rebuild-plugin/pull/45 Rebuilds seem to work correctly after changing the one .jelly file. Hopefully they'll accept the PR.

          Show
          ejpenney Emory Penney added a comment - I've had success with this: https://github.com/jenkinsci/rebuild-plugin/pull/45 Rebuilds seem to work correctly after changing the one .jelly file. Hopefully they'll accept the PR.
          Hide
          nealmac01 Neal Macdonald added a comment - - edited

          Node parameter is repopulated again on 'Rebuild Last' - Jenkins 2.45

          Show
          nealmac01 Neal Macdonald added a comment - - edited Node parameter is repopulated again on 'Rebuild Last' - Jenkins 2.45
          Hide
          gustafl Gustaf Lundh added a comment -

          I have verified and merged Emory Penney's PR here: https://github.com/jenkinsci/rebuild-plugin/pull/45

          Will issue a new release later this month.

           

          Show
          gustafl Gustaf Lundh added a comment - I have verified and merged  Emory Penney 's PR here: https://github.com/jenkinsci/rebuild-plugin/pull/45 Will issue a new release later this month.  

            People

            • Assignee:
              ejpenney Emory Penney
              Reporter:
              ejpenney Emory Penney
            • Votes:
              2 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: