Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-38692

Add extra fine grained logging to JNLPv4 protocol

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Done
    • Component/s: remoting
    • Labels:
      None
    • Similar Issues:

      Description

      In discovering JENKINS-38690 and JENKINS-38691 I had to add extra logging to the code.
      Given that this is exceptionally useful logging to be able to turn on it should be added to the code if it does not have a significant performance degredation.

        Attachments

          Issue Links

            Activity

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: James Nord
            Path:
            src/main/java/org/jenkinsci/remoting/protocol/IOHub.java
            src/main/java/org/jenkinsci/remoting/protocol/impl/NIONetworkLayer.java
            http://jenkins-ci.org/commit/remoting/46c72a5530a0b2757350e33262ae17c981dcd13a
            Log:
            JENKINS-38692 Add extra logging to help diagnosing Thread spike. (#116)

            Add extra logging statements to try and get to the root cause
            of the IOHub thread spike.

            oleg_nenashev Oleg Nenashev added a comment -

            The fix has been integrated towards remoting-3.1

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Oleg Nenashev
            Path:
            pom.xml
            http://jenkins-ci.org/commit/jenkins/7a948d399585d201c4132597aed5723a495acf69
            Log:
            Update remoting to 2.31 in the Jenkins core. (#2628)

            The change introduces one serious bugfix (JENKINS-39596) and a bunch of various diagnostics improvements.

            Bugfixes:

            Improvements:

            oleg_nenashev Oleg Nenashev added a comment -

            The fix has been integrated towards jenkins-2.31


              People

              • Assignee:
                teilo James Nord
                Reporter:
                teilo James Nord
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: