Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-39711

Unity build not installing scenes

    Details

    • Similar Issues:

      Description

      I'm currently attempting to setup an automated Jenkins build of a Unity 5.4.1f1 project on a Windows server.

      Attached is the buildscript I'm calling from the command line with the command:

      "C:\Program Files\Unity\Editor\Unity.exe" -batchmode -quit -executeMethod BuildScript.PerformWindows64Build -projectPath "<SuperImportantProjectPath>" -logFile "<SuperImportantProjectPath>\SuperImportantProject.log"

      If I build this on the server using the GUI Build Settings, it builds fine. If I build it through the menu created by the build script, it builds fine. If I build it from the command line, it builds fine. If I build it in Jenkins, whether via a batch command or the Unity3d plugin, it fails to load any scenes when you attempt to run it.

      The logs for the successful vs unsuccessful are exactly the same until these lines appear in the unsuccessful output log:

      {{(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)
      No downloadData scenes in CurrentApplicationInfo. Cancelling load...
      (Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)
      DontDestroyOnLoad only work for root GameObjects or components on root GameObjects.
      (Filename: Line: 386)}}

      I've included the full log file.

        Attachments

          Activity

          There are no comments yet on this issue.

            People

            • Assignee:
              lacostej lacostej
              Reporter:
              cameronshiell Cameron Shiell
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated: