Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-39820

The server rejected the connection: None of the protocols were accepted

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Cannot Reproduce
    • Component/s: swarm-plugin
    • Labels:
      None
    • Environment:
      Jenkins version 2.19.1
    • Similar Issues:

      Description

      hello,

      could you tel me why when my slave want connect to master using IP address master is success ?
      and when i want connect to by domain provided it is show error.

      i'm using swarm plugin.

      Nov 17, 2016 7:08:34 PM hudson.remoting.jnlp.Main$CuiListener error
      SEVERE: The server rejected the connection: None of the protocols were accepted
      java.lang.Exception: The server rejected the connection: None of the protocols were accepted
      at hudson.remoting.Engine.onConnectionRejected(Engine.java:366)
      at hudson.remoting.Engine.run(Engine.java:338)

      for example:
      java -jar swarm-client-jar-with-dependencies.jar -master x.x.x.x (other parameter) => success

      but
      java -jar swarm-client-jar-with-dependencies.jar -master test.jenkins.id (other parameter) => is result error
      Nov 17, 2016 7:13:34 PM hudson.remoting.jnlp.Main createEngine
      INFO: Setting up slave: PHP-CSF-PROD
      Nov 17, 2016 7:13:34 PM hudson.remoting.jnlp.Main$CuiListener <init>
      INFO: Jenkins agent is running in headless mode.
      Nov 17, 2016 7:13:34 PM hudson.remoting.jnlp.Main$CuiListener status
      INFO: Locating server among https://******.id/
      Nov 17, 2016 7:13:34 PM hudson.remoting.jnlp.Main$CuiListener status
      INFO: Handshaking
      Nov 17, 2016 7:13:34 PM hudson.remoting.jnlp.Main$CuiListener status
      INFO: Connecting to ******.id:50000
      Nov 17, 2016 7:13:34 PM hudson.remoting.jnlp.Main$CuiListener status
      INFO: Trying protocol: JNLP3-connect
      Nov 17, 2016 7:13:34 PM hudson.remoting.jnlp.Main$CuiListener status
      INFO: Server didn't accept the handshake: HTTP/1.1 400 Bad Request
      Nov 17, 2016 7:13:34 PM hudson.remoting.jnlp.Main$CuiListener status
      INFO: Connecting to *********id:50000
      Nov 17, 2016 7:13:34 PM hudson.remoting.jnlp.Main$CuiListener status
      INFO: Trying protocol: JNLP2-connect
      Nov 17, 2016 7:13:34 PM hudson.remoting.jnlp.Main$CuiListener status
      INFO: Server didn't accept the handshake: HTTP/1.1 400 Bad Request
      Nov 17, 2016 7:13:34 PM hudson.remoting.jnlp.Main$CuiListener status
      INFO: Connecting to ********.id:50000
      Nov 17, 2016 7:13:34 PM hudson.remoting.jnlp.Main$CuiListener status
      INFO: Trying protocol: JNLP-connect
      Nov 17, 2016 7:13:34 PM hudson.remoting.jnlp.Main$CuiListener status
      INFO: Server didn't accept the handshake: HTTP/1.1 400 Bad Request
      Nov 17, 2016 7:13:34 PM hudson.remoting.jnlp.Main$CuiListener status
      INFO: Connecting to ********.id:50000
      Nov 17, 2016 7:13:34 PM hudson.remoting.jnlp.Main$CuiListener error
      SEVERE: The server rejected the connection: None of the protocols were accepted
      java.lang.Exception: The server rejected the connection: None of the protocols were accepted
      at hudson.remoting.Engine.onConnectionRejected(Engine.java:366)
      at hudson.remoting.Engine.run(Engine.java:338)

      i had verified the firewall and ok.

        Attachments

          Activity

          jekeller Jacob Keller added a comment -

          I am having the same issue. I suspect it is because the remoting API in jenkins and the swarm client don't match.

          ntest Ritcha S added a comment -

          Hi,

          Have you resolved the issue?

          basil Basil Crow added a comment -

          Cannot reproduce this issue with the latest LTS release of Jenkins, the latest release of the Swarm plugin, and the latest release Swarm client. If this issue is encountered again, please open a new bug with steps to reproduce from scratch.


            People

            • Assignee:
              Unassigned
              Reporter:
              halasson halasson simatupang
            • Votes:
              1 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: