Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-40181

Job DSL githubPullRequest: No signature of method with Jenkins 2.x

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Not A Defect
    • Labels:
      None
    • Environment:
      Jenkins 2.19.1
      Job DSL Plugin 1.51
      GHPRB 1.33.2
      Ubuntu 14.04
    • Similar Issues:

      Description

      Continue of JENKINS-37647.

      I checkout DSL test repo from job-dsl-gradle-example and run tests successfully on my Ubuntu with Jenkins.

      But when I changed Jenkins version to 2.19.1 tests fails with error:

      Caused by:
      10:57:43.638 [DEBUG] [TestEventLogger] javaposse.jobdsl.dsl.DslScriptException: (script, line 72) No signature of method: javaposse.jobdsl.dsl.helpers.triggers.TriggerContext.githubPullRequest() is applicable for argument types: (script$_run_closure2$_closure8$_closure9) values: [script$_run_closure2$_closure8$_closure9@4c560437]
      

      Changing back Jenkins version solved this issue.

      Then I try to use

      ./gradlew rest
      

      to create job without tests - fails again with the same error.

      Interesting note: tests runs successfully on my macOS with any Jenkins version. I found same issue: job-dsl-gradle-example/issues/64

        Attachments

          Activity

          daspilker Daniel Spilker added a comment -

          I can't reproduce this. Here is the code where I updated Jenkins to 2.19.1 and GHPRB to 1.33.2: https://github.com/daspilker/job-dsl-gradle-example/tree/JENKINS-40181
          ./gradlew clean build runs successfully.

          daspilker Daniel Spilker added a comment -

          Ah, sorry. I tested this on Windows. I can reproduce this when running on Ubunto 14.04 (in a ubuntu:14.04 docker container).

          This PR fixes the problem: https://github.com/sheehan/job-dsl-gradle-example/pull/70

          daspilker Daniel Spilker added a comment -

          I'm closing this since it's a job-dsl-gradle-example problem and not a Job DSL or GHBRB plugin bug. This is tracked as #63 and #64 in the job-dsl-gradle-example repo.


            People

            • Assignee:
              daspilker Daniel Spilker
              Reporter:
              lawyard LawYard LawYard
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: