Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-40644

Trigger Release with two or more Artifacs (one Jenkins and another Git) fails with "Could not fetch versions for the linked artifact" for the Git one

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Component/s: tfs-plugin
    • Labels:
      None
    • Environment:
      Jenkins ver. 2.19.2
      TFS plugin 5.2.1
    • Similar Issues:

      Description

      In Team Services I have a Release Definition with several artifacts (one from Jenkins [primary] and another from Git). The trigger to the VSTS fails with the log below.

      Fetching latest version for artifact: InternalTasks
      ERROR: Failed to trigger release.%n
      hudson.plugins.tfs.rm.ReleaseManagementException: Could not fetch versions for the linked artifact: InternalTasks
      	at hudson.plugins.tfs.rm.ReleaseManagementCI.PrepareReleaseArtifacts(ReleaseManagementCI.java:189)
      	at hudson.plugins.tfs.rm.ReleaseManagementCI.CreateRelease(ReleaseManagementCI.java:144)
      	at hudson.plugins.tfs.rm.ReleaseManagementCI.perform(ReleaseManagementCI.java:104)
      	at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:779)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:720)
      	at hudson.model.Build$BuildExecution.post2(Build.java:185)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:665)
      	at hudson.model.Run.execute(Run.java:1745)
      	at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
      	at hudson.model.ResourceController.execute(ResourceController.java:98)
      	at hudson.model.Executor.run(Executor.java:404)
      

      If I remove the "InternalTasks" [Git] artifact link then the trigger works perfectly.

      In attachment it is possible to see that the Git artifacts have several version (which is prompt in the error above).

        Attachments

          Activity

          Hide
          kelliejos Kellie Jos added a comment -

          Thank you for using the tfs-plugin. It appears that your issue was found in an older version of the plugin. There have been a number of improvements made in the recent releases that may have resolved your issue. Please update to the most recent 5.126.0 release. If your issue persists, please open a new ticket and we will investigate.

          Show
          kelliejos Kellie Jos added a comment - Thank you for using the tfs-plugin. It appears that your issue was found in an older version of the plugin. There have been a number of improvements made in the recent releases that may have resolved your issue. Please update to the most recent 5.126.0 release. If your issue persists, please open a new ticket and we will investigate.
          Hide
          daveparso david parsonson added a comment -

          Using 5.133.0 and this issue is still occuring

          Show
          daveparso david parsonson added a comment - Using 5.133.0 and this issue is still occuring

            People

            • Assignee:
              redsolo redsolo
              Reporter:
              ctorrao Carlos Torrao
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: