Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-41967

AWS Credentials Plugin v1.17+ is not API-compatible with ec2-plugin

    XMLWordPrintable

    Details

    • Similar Issues:

      Attachments

        Issue Links

          Activity

          Hide
          andresrc Andres Rodriguez added a comment -

          Released as version 1.20

          Show
          andresrc Andres Rodriguez added a comment - Released as version 1.20
          Hide
          cleclerc Cyrille Le Clerc added a comment -

          Fix confirmed: I could successfully build org.jenkins-ci.plugins:ec2 with org.jenkins-ci.plugins:aws-credentials:1.20 when it is failing with aws-credentials:1.19.

          Exception compiling the EC2 Plugin with org.jenkins-ci.plugins:aws-credentials:1.19

          [ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:3.3:compile (default-compile) on project ec2: Compilation failure
          [ERROR] /Users/cyrilleleclerc/git/jenkins/ec2-plugin/src/main/java/hudson/plugins/ec2/EC2Cloud.java:[231,74] constructor AWSCredentialsImpl in class com.cloudbees.jenkins.plugins.awscredentials.AWSCredentialsImpl cannot be applied to given types;
          [ERROR]   required: com.cloudbees.plugins.credentials.CredentialsScope,java.lang.String,java.lang.String,java.lang.String,java.lang.String,java.lang.String,java.lang.String
          [ERROR]   found: com.cloudbees.plugins.credentials.CredentialsScope,java.lang.String,java.lang.String,java.lang.String,java.lang.String
          [ERROR]   reason: actual and formal argument lists differ in length
          
          Show
          cleclerc Cyrille Le Clerc added a comment - Fix confirmed: I could successfully build org.jenkins-ci.plugins:ec2 with org.jenkins-ci.plugins:aws-credentials:1.20 when it is failing with aws-credentials:1.19. Exception compiling the EC2 Plugin with org.jenkins-ci.plugins:aws-credentials:1.19 [ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:3.3:compile (default-compile) on project ec2: Compilation failure [ERROR] /Users/cyrilleleclerc/git/jenkins/ec2-plugin/src/main/java/hudson/plugins/ec2/EC2Cloud.java:[231,74] constructor AWSCredentialsImpl in class com.cloudbees.jenkins.plugins.awscredentials.AWSCredentialsImpl cannot be applied to given types; [ERROR] required: com.cloudbees.plugins.credentials.CredentialsScope,java.lang.String,java.lang.String,java.lang.String,java.lang.String,java.lang.String,java.lang.String [ERROR] found: com.cloudbees.plugins.credentials.CredentialsScope,java.lang.String,java.lang.String,java.lang.String,java.lang.String [ERROR] reason: actual and formal argument lists differ in length

            People

            • Assignee:
              andresrc Andres Rodriguez
              Reporter:
              arcivanov Arcadiy Ivanov
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: