Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-42318

UI Not Refreshing When Starting a Build

    XMLWordPrintable

    Details

    • Sprint:
      Blue Ocean 1.0-rc3, Blue Ocean 1.0-rc4, Blue Ocean - 1.1-beta-1, Blue Ocean - 1.1-beta2
    • Similar Issues:

      Description

      I am on the latest Jenkins and latest Blue Ocean plugins (fresh install) on CentOS 7. I am using the latest Chrome on MacOS Sierra.

      When I run a build I get the waiting for build to start screen. If I refresh the pipeline has started and is halfway finished. Here is JS error I see in the console:

      [ERROR - io.jenkins.blueocean.dashboard.harmonizeTimes] not found any startTime, seems that a component should not have called this me
      error @ blueocean.js:17977

        Attachments

        1. errors.png
          errors.png
          216 kB
        2. errors.txt
          66 kB
        3. Feb-27-2017 16-22-09.gif
          Feb-27-2017 16-22-09.gif
          216 kB
        4. Jenkinsfile
          2 kB

          Issue Links

            Activity

            Hide
            jamesdumay James Dumay added a comment -

            We are doing some re-engineering of the running pipeline view in JENKINS-38523 that should solve some systematic issues like this one. We will revisit soon.

            Show
            jamesdumay James Dumay added a comment - We are doing some re-engineering of the running pipeline view in JENKINS-38523 that should solve some systematic issues like this one. We will revisit soon.
            Hide
            tscherler Thorsten Scherler added a comment -

            Josh Axelman sorry for taking so long, but you can try https://github.com/jenkinsci/blueocean-plugin/pull/839 which is in review and see whether it fixes your issue. I strongly believe it will.

            Show
            tscherler Thorsten Scherler added a comment - Josh Axelman  sorry for taking so long, but you can try https://github.com/jenkinsci/blueocean-plugin/pull/839  which is in review and see whether it fixes your issue. I strongly believe it will.
            Hide
            joshaxelman Josh Axelman added a comment -

            Thorsten Scherler, I installed BlueOcean from the Jenkins Plugin Manager. I am not sure how to test a specific branch. Based on the comments in thread it seems like it should fix the issue. 

            Show
            joshaxelman Josh Axelman added a comment - Thorsten Scherler , I installed BlueOcean from the Jenkins Plugin Manager. I am not sure how to test a specific branch. Based on the comments in thread it seems like it should fix the issue. 
            Hide
            michaelneale Michael Neale added a comment -

            Josh Axelman yes would have to build it from source, which is a bit more of a time investment. Just keep an eye on this for when this comes out in a future release and check back. 

            Show
            michaelneale Michael Neale added a comment - Josh Axelman yes would have to build it from source, which is a bit more of a time investment. Just keep an eye on this for when this comes out in a future release and check back. 
            Hide
            jamesdumay James Dumay added a comment -

            Will be released in Blue Ocean 1.1

            Show
            jamesdumay James Dumay added a comment - Will be released in Blue Ocean 1.1

              People

              • Assignee:
                tscherler Thorsten Scherler
                Reporter:
                joshaxelman Josh Axelman
              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: