Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-42549

Maven version detection fails on same agent with 'java.lang.IllegalStateException: zip file closed' exception

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Blocker
    • Resolution: Fixed
    • Component/s: maven-plugin
    • Labels:
    • Environment:
    • Similar Issues:

      Description

      Have setup 4 jenkins jobs to run on the same node, and a job that triggers all 4 jobs at the same time

      job-parent -> maven-job1
      maven-job2
      maven-job3
      maven-job4

      When Running job-parent almost every time 2-3 jobs out of 4 fail at checking out the code with the following exception:
       

      Started by upstream project "SanityLinux-UBUNTU14.04-D1-EXT4" build number 4
      originally caused by:
       Started by user Administrator
      Building remotely on Sanity-Pool01-AutoSlaveLinux (windows) in workspace c:\jenkins\workspace\SanityLinux-UBUNTU14.04-D1-EXT4-D2-LVM-EXT4
      Fetching changes from the remote Git repository
      Checking out Revision 01b711db99104fcdd4a0946ac1ad5e5ee8d248dc (origin/7.25)
      ERROR: Processing failed due to a bug in the code. Please report this to jenkinsci-users@googlegroups.com
      java.lang.IllegalStateException: zip file closed
      	at java.util.zip.ZipFile.ensureOpen(Unknown Source)
      	at java.util.zip.ZipFile.getEntry(Unknown Source)
      	at java.util.jar.JarFile.getEntry(Unknown Source)
      	at sun.net.www.protocol.jar.URLJarFile.getEntry(Unknown Source)
      	at sun.net.www.protocol.jar.JarURLConnection.connect(Unknown Source)
      	at sun.net.www.protocol.jar.JarURLConnection.getJarFile(Unknown Source)
      	at hudson.maven.MavenEmbedderUtils.getMavenVersion(MavenEmbedderUtils.java:212)
      	at hudson.maven.MavenVersionCallable.call(MavenVersionCallable.java:69)
      	at hudson.maven.MavenVersionCallable.call(MavenVersionCallable.java:41)
      	at hudson.remoting.UserRequest.perform(UserRequest.java:153)
      	at hudson.remoting.UserRequest.perform(UserRequest.java:50)
      	at hudson.remoting.Request$2.run(Request.java:336)
      	at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:68)
      	at java.util.concurrent.FutureTask.run(Unknown Source)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
      	at hudson.remoting.Engine$1$1.run(Engine.java:94)
      	at java.lang.Thread.run(Unknown Source)
      	at ......remote call to Channel to /10.11.6.120(Native Method)
      	at hudson.remoting.Channel.attachCallSiteStackTrace(Channel.java:1537)
      	at hudson.remoting.UserResponse.retrieve(UserRequest.java:253)
      	at hudson.remoting.Channel.call(Channel.java:822)
      	at hudson.FilePath.act(FilePath.java:1080)
      	at hudson.maven.MavenModuleSetBuild$MavenModuleSetBuildExecution.doRun(MavenModuleSetBuild.java:642)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:534)
      	at hudson.model.Run.execute(Run.java:1728)
      	at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:544)
      	at hudson.model.ResourceController.execute(ResourceController.java:98)
      	at hudson.model.Executor.run(Executor.java:404)
      project=hudson.maven.MavenModuleSet@44df909[SanityLinux-UBUNTU14.04-D1-EXT4-D2-LVM-EXT4]
      project.getModules()=[hudson.maven.MavenModule@197eae6e[SanityLinux-UBUNTU14.04-D1-EXT4-D2-LVM-EXT4/com.winmagic.qa:automation-tests][SanityLinux-UBUNTU14.04-D1-EXT4-D2-LVM-EXT4/com.winmagic.qa:automation-tests][relativePath:]]
      project.getRootModule()=hudson.maven.MavenModule@197eae6e[SanityLinux-UBUNTU14.04-D1-EXT4-D2-LVM-EXT4/com.winmagic.qa:automation-tests][SanityLinux-UBUNTU14.04-D1-EXT4-D2-LVM-EXT4/com.winmagic.qa:automation-tests][relativePath:]
      FATAL: zip file closed
      java.lang.IllegalStateException: zip file closed
      	at java.util.zip.ZipFile.ensureOpen(Unknown Source)
      	at java.util.zip.ZipFile.getEntry(Unknown Source)
      	at java.util.jar.JarFile.getEntry(Unknown Source)
      	at sun.net.www.protocol.jar.URLJarFile.getEntry(Unknown Source)
      	at sun.net.www.protocol.jar.JarURLConnection.connect(Unknown Source)
      	at sun.net.www.protocol.jar.JarURLConnection.getJarFile(Unknown Source)
      	at hudson.maven.MavenEmbedderUtils.getMavenVersion(MavenEmbedderUtils.java:212)
      	at hudson.maven.MavenVersionCallable.call(MavenVersionCallable.java:69)
      	at hudson.maven.MavenVersionCallable.call(MavenVersionCallable.java:41)
      	at hudson.remoting.UserRequest.perform(UserRequest.java:153)
      	at hudson.remoting.UserRequest.perform(UserRequest.java:50)
      	at hudson.remoting.Request$2.run(Request.java:336)
      	at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:68)
      	at java.util.concurrent.FutureTask.run(Unknown Source)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
      	at hudson.remoting.Engine$1$1.run(Engine.java:94)
      	at java.lang.Thread.run(Unknown Source)
      	at ......remote call to Channel to /10.11.6.120(Native Method)
      	at hudson.remoting.Channel.attachCallSiteStackTrace(Channel.java:1537)
      	at hudson.remoting.UserResponse.retrieve(UserRequest.java:253)
      	at hudson.remoting.Channel.call(Channel.java:822)
      	at hudson.FilePath.act(FilePath.java:1080)
      	at hudson.maven.MavenModuleSetBuild$MavenModuleSetBuildExecution.doRun(MavenModuleSetBuild.java:642)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:534)
      	at hudson.model.Run.execute(Run.java:1728)
      	at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:544)
      	at hudson.model.ResourceController.execute(ResourceController.java:98)
      	at hudson.model.Executor.run(Executor.java:404)
      Finished: FAILURE
      

        Attachments

          Issue Links

            Activity

            markewaite Mark Waite added a comment -

            As far as I can tell from the stack trace, this has nothing to do with the git plugin.

            If you can provide detailed steps to duplicate the problem, it will help whoever eventually needs to fix it.

            jochenafuerbacher Jochen A. Fürbacher added a comment -

            Same problem here.

            Jenkins core 2.46
            Maven Intergration Plugin 2.15.1

            We have about 1000 job building every night. About 10-15 jobs of these 1000 fail with the exception Andrei Caragheorghii mentioned. They are not always the same jobs that fail.

            As a workaround deleting the workspace and rebuilding the jobs works for the moment.

            aaron312 Aaron Curley added a comment - - edited

            Same issue with our Jenkins install.  For us, it seems that builds triggered by an upstream project's change induce the build failures.

            The issue appeared when we upgraded the Maven Integration plugin from 2.14 to 2.15.1.  

            We are running Jenkins LTS 2.32.3 on OEL 6, 64-bit.

            Edit:  Also, this is unrelated to git; we are currently using svn for most of our projects and it still results in this failure.

             

            creathor Waldemar Kotarba added a comment -

            Same issue with Jenkins 2.19.2, Maven IntegrationPlugin 2.15.1, Java OpenJDK 1.7.0_111, Debian 8 64-bit

            vadipp Vadim Ippolitov added a comment -

            We have the same issue on Jenkins ver. 2.52 (with Maven Integration plugin 2.15.1). Sorry, don't have access to OS details.

            It happens when a nightly scheduled job starts four instances of another job at the same time (with different parameters).

            Seems like the issue has appeared after some latest update. Meanwhile I will try to downgrade the Maven Integration plugin to 2.14 as hinted above.

            aheritier Arnaud Héritier added a comment -

            Potentially related to the maven embedder upgrade we did with Oleg Nenashev in 2.15.x

            This part of the code was updated as part of JENKINS-40621 done by Andrew Bayer

            https://github.com/jenkinsci/lib-jenkins-maven-embedder/commit/9b4742831da240bbdd6b3adcd8fe53c2088927f3

            marco_rothe Marco Rothe added a comment -

            Same issue with Jenkins 2.53 and Maven Integration plugin 2.15.1.

            Jenkins run on Windows Server 2012R2  and slaves on Ubuntu 16.04.2 LTS (GNU/Linux 4.4.0-31-generic x86_64). Both use Java 1.8.0_92-b14 (Java HotSpot(TM) 64-Bit Server VM (build 25.92-b14, mixed mode)).

            tenety Andrei Khveras added a comment -

            This might be related to SDK bug:

            http://bugs.java.com/bugdatabase/view_bug.do?bug_id=7050028

            They suggest a few workarounds at the bottom.

            marco_rothe Marco Rothe added a comment -

            We use a fairly current JDK 8 (1.8.0_92-b14) on master and slaves so I doubt that it is releated to this old SDK bug.

            Downgrading Maven Integration from 2.15.1 to 2.14 "fixed" the problem. So I think that the comment of Arnaud Héritier (comment-294033) point to the right direction.

            aheritier Arnaud Héritier added a comment -

            Could you tell me how the maven job is configured when you have this issue ?

            I understand that it appears when several maven builds are occurring ~ at the same time on the same agent

            The problem occurs when Jenkins tries to detect the maven version used

            When you saw this problem, maven was already installed or some jobs tried to install maven on the agent ?

            vadipp Vadim Ippolitov added a comment -

            Can't tell about the OP, but in my case all the jobs were run on the master node, and maven was already installed there.

            aheritier Arnaud Héritier added a comment -

            thx Vadim Ippolitov

            And others ? Do you have also this problem on master only ? Or is it impacting classical agents too ?

            marco_rothe Marco Rothe added a comment - - edited

            The problem occurs if builds start "at the same time" (downstream projects) on the same slave (4 build processors). Maven was already installed.

             

            Edit: We run no builds on the master.

            tenety Andrei Khveras added a comment -

            +1 to Marco Rothe

            We experience the issue at the slave when our multi job starts a number of child jobs (that use Maven Integration plugin) simultaneously. I can't confirm if it would happen at the Jenkins master.

            Reproducible at both vv 2.14 and 2.15.

            aheritier Arnaud Héritier added a comment -

            You have the same issue with 2.14 ?

            Because it changes the problem if it is the case. 

            marco_rothe Marco Rothe added a comment -

            In our enviroment the problem gone away after we downgrade the plugin to 2.14

            tenety Andrei Khveras added a comment -

            Arnaud Héritier, sorry for misleading you.

            I double checked - problem does go away after downgrade to 2.14.

            aheritier Arnaud Héritier added a comment -

            ok great Andrei Khveras

             

            mlynnyk Mykola Lynnyk added a comment -

            I've already commented on the duplicate JENKINS-43393. I can confirm that the findings listed in the comments here are correct - indeed, the problem goes away after downgrading to 2.14 (featuring lib-jenkins-maven-embedder-3.11), and indeed, I also believe it to be a regression introduced by the fix for JENKINS-40621.

            pingunaut Martin Spielmann added a comment -

            Confirmed for Jenkins 2.60 and Maven Integration Plugin 2.15.1 (Java 1.8.0_92-b14)
            After downgrading to 2.14, everything is running smooth again.

            oleg_nenashev Oleg Nenashev added a comment -
            aheritier Arnaud Héritier added a comment - - edited

             but nice finding Oleg Nenashev

            andrei_caragheorghii Andrei Caragheorghii added a comment -

            Arnaud Héritier any plans to fix this issue?

            aheritier Arnaud Héritier added a comment -

            There is an upgrade in progress of Jetty by Olivier Lamy but I'm not sure it can fix this
            This fix is checked in (using the bug number 401485) for jetty-8.1.10 and jetty-9.0.0.RC1
            The problem is that it's not a fix at the maven plugin level. I need to discuss with Andrew Bayer, Oleg Nenashev and Olivier Lamy if we could find a better solution which doesn't rely on jenkins core

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Oleg Nenashev
            Path:
            pom.xml
            src/main/java/hudson/maven/MavenEmbedderCallable.java
            src/main/java/hudson/maven/MavenEmbedderUtils.java
            src/test/java/hudson/maven/TestMavenEmbedderUtils.java
            http://jenkins-ci.org/commit/lib-jenkins-maven-embedder/e579f8ad3f8af5274662152afdd361762183bde8
            Log:
            JENKINS-42549 - Reproduce the issue in tests

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Oleg Nenashev
            Path:
            src/main/java/hudson/maven/MavenEmbedderUtils.java
            http://jenkins-ci.org/commit/lib-jenkins-maven-embedder/626ddba71616fd1b10a66e627140c754dd6be443
            Log:
            JENKINS-42549 - Prevent collision of files when reading them in parallel

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Olivier Lamy
            Path:
            pom.xml
            src/main/java/hudson/maven/MavenEmbedderCallable.java
            src/main/java/hudson/maven/MavenEmbedderUtils.java
            src/test/java/hudson/maven/TestMavenEmbedderUtils.java
            http://jenkins-ci.org/commit/lib-jenkins-maven-embedder/9229e4be5d5d3667de6ae97161f09596826c6798
            Log:
            Merge pull request #13 from oleg-nenashev/JENKINS-42549

            [JENKINS-42549, JENKINS-40621] - Handle fallout after #5

            Compare: https://github.com/jenkinsci/lib-jenkins-maven-embedder/compare/bcac0b5bd889...9229e4be5d5d

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Oleg Nenashev
            Path:
            pom.xml
            http://jenkins-ci.org/commit/maven-plugin/8983583f2ed58734da3edd1b72428476bcd1a5a9
            Log:
            [JENKINS-42549, JENKINS-40621] - Update the Maven Embedder Lib to 3.12.1

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Oleg Nenashev
            Path:
            pom.xml
            http://jenkins-ci.org/commit/maven-plugin/c068c94037bc76172b682175878dbdd4c01f163a
            Log:
            [JENKINS-42549, JENKINS-40621] - Update the Maven Embedder Lib to 3.12.1

            oleg_nenashev Oleg Nenashev added a comment -

            The fix has been released in Maven Plugin 2.17 and Maven Embedder Lib 3.12.1

            Please confirm the fix

            andrei_caragheorghii Andrei Caragheorghii added a comment -

            Oleg Nenashev I just need to update the Maven Plugin to 2.17 for the fix?
            I have Jenkins 2.60.1 version

            oleg_nenashev Oleg Nenashev added a comment -

            Andrei Caragheorghii yes. It may take few hours for this version to get to update centers. But I already see it in my one

            mlynnyk Mykola Lynnyk added a comment -

            The problem is back with 3.0-rc1, reproduced almost immediately after the upgrade; 2.17 appears to be safe to use, with it the problem wasn't seen for months.

             

            FATAL: zip file closed
            java.lang.IllegalStateException: zip file closed
            	at java.util.zip.ZipFile.ensureOpen(Unknown Source)
            	at java.util.zip.ZipFile.getEntry(Unknown Source)
            	at java.util.jar.JarFile.getEntry(Unknown Source)
            	at sun.net.www.protocol.jar.URLJarFile.getEntry(Unknown Source)
            	at java.util.jar.JarFile.getJarEntry(Unknown Source)
            	at hudson.maven.MavenEmbedderUtils.getMavenVersion(MavenEmbedderUtils.java:213)
            	at hudson.maven.MavenVersionCallable.call(MavenVersionCallable.java:69)
            	at hudson.maven.MavenVersionCallable.call(MavenVersionCallable.java:41)
            	at hudson.remoting.UserRequest.perform(UserRequest.java:153)
            	at hudson.remoting.UserRequest.perform(UserRequest.java:50)
            	at hudson.remoting.Request$2.run(Request.java:336)
            	at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:68)
            	at java.util.concurrent.FutureTask.run(Unknown Source)
            	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
            	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
            	at hudson.remoting.Engine$1$1.run(Engine.java:94)
            	at java.lang.Thread.run(Unknown Source)
            	at ......remote call to Channel to /10.90.208.112(Native Method)
            	at hudson.remoting.Channel.attachCallSiteStackTrace(Channel.java:1545)
            	at hudson.remoting.UserResponse.retrieve(UserRequest.java:253)
            	at hudson.remoting.Channel.call(Channel.java:830)
            	at hudson.FilePath.act(FilePath.java:1082)
            	at hudson.maven.MavenModuleSetBuild$MavenModuleSetBuildExecution.doRun(MavenModuleSetBuild.java:641)
            	at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:490)
            	at hudson.model.Run.execute(Run.java:1735)
            	at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:543)
            	at hudson.model.ResourceController.execute(ResourceController.java:97)
            	at hudson.model.Executor.run(Executor.java:405)
            
            mlynnyk Mykola Lynnyk added a comment -

            The problem is reproducible again with the latest available version of the plugin - 3.0-rc1. It has clearly been fixed in 2.17.

            aheritier Arnaud Héritier added a comment -

            thanks Mykola Lynnyk

            Oleg Nenashev I think it is better to open a new issue and link to this one ? WDYT ?

            oleg_nenashev Oleg Nenashev added a comment -

            A new issue would be better

            aheritier Arnaud Héritier added a comment -

            I opened JENKINS-47233 for the issue impacting the 3.0-rc1. This one was fixed in 2.17

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Oleg Nenashev
            Path:
            pom.xml
            http://jenkins-ci.org/commit/maven-plugin/8893af0751e819c09e6184103bdf24285747fd7a
            Log:
            JENKINS-47233 - Restore the fix of JENKINS-42549

            The fix has been reverted in 3.0.0-rc1 by https://github.com/jenkinsci/maven-plugin/pull/102.
            It was just a mistake I made when patching the dependencies, but unfortunately nobody noticed it during the code review.

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Arnaud Heritier
            Path:
            pom.xml
            http://jenkins-ci.org/commit/maven-plugin/a267e66db9aa062251f3ee493cf2431c2c0a1f6d
            Log:
            Merge pull request #104 from oleg-nenashev/JENKINS-47233

            JENKINS-47233 - Restore the fix of JENKINS-42549

            Compare: https://github.com/jenkinsci/maven-plugin/compare/298861e13211...a267e66db9aa


              People

              • Assignee:
                oleg_nenashev Oleg Nenashev
                Reporter:
                andrei_caragheorghii Andrei Caragheorghii
              • Votes:
                21 Vote for this issue
                Watchers:
                31 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: