Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-42599

Newly added module locations' / additional credentials' "Add" credential button seems out of work

    Details

    • Similar Issues:

      Description

      As the screenshot below,

      in the second added module block, Add button in Credentials Block can not pop out any dialog...

      The Additional Credentials part has the same problem. 

        Attachments

          Issue Links

            Activity

            Hide
            vlatombe Vincent Latombe added a comment -

            Raphael Pionke I think it would just be one more hack on top of the existing one so I wouldn't be too happy to file it.

            Show
            vlatombe Vincent Latombe added a comment - Raphael Pionke I think it would just be one more hack on top of the existing one so I wouldn't be too happy to file it.
            Hide
            rpionke Raphael Pionke added a comment -

            Vincent Latombe so should we create a PR to increase the timeout?

            Show
            rpionke Raphael Pionke added a comment - Vincent Latombe so should we create a PR to increase the timeout?
            Hide
            vlatombe Vincent Latombe added a comment - - edited

            Caused by the workaround for JENKINS-26578 (source).

            It causes the YUI button in the 'template' block used by repeatable to be rendered before the html text is captured by repeatable behaviour initialization.

            Then later, when it is inserted, the behaviour doesn't work properly since the markup is not what is expected.

            If I set a larger timeout in the JENKINS-26578 hack, then the new entries get added properly and the 'add' button works fine.

            Show
            vlatombe Vincent Latombe added a comment - - edited Caused by the workaround for  JENKINS-26578 ( source ). It causes the YUI button in the 'template' block used by repeatable to be rendered before the html text is captured by repeatable behaviour initialization . Then later, when it is inserted, the behaviour doesn't work properly since the markup is not what is expected. If I set a larger timeout in the JENKINS-26578 hack, then the new entries get added properly and the 'add' button works fine.
            Show
            rpionke Raphael Pionke added a comment - yes, see  https://issues.jenkins-ci.org/browse/JENKINS-42546
            Hide
            jglick Jesse Glick added a comment -

            Problem in credentials plugin?

            Show
            jglick Jesse Glick added a comment - Problem in credentials plugin?

              People

              • Assignee:
                Unassigned
                Reporter:
                aliyun_containerservice Aliyun ContainerService
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated: