Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-4275

Could not find "cygpath"

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: plugin-proposals
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      Started by user anonymous
      Building remotely on asqe-xeon-4.sfbay.sun.com
      Allocating TCP port 8080
      TCP port allocation complete
      FATAL: command execution failed
      java.io.IOException: Cannot run program "cygpath": CreateProcess error=2, The
      system cannot find the file specified
      at java.lang.ProcessBuilder.start(Unknown Source)
      at hudson.Proc$LocalProc.<init>(Proc.java:145)
      at hudson.Proc$LocalProc.<init>(Proc.java:118)
      at hudson.Launcher$LocalLauncher.launch(Launcher.java:633)
      at hudson.Launcher$ProcStarter.start(Launcher.java:268)
      at hudson.Launcher$RemoteLaunchCallable.call(Launcher.java:773)
      at hudson.Launcher$RemoteLaunchCallable.call(Launcher.java:751)
      at hudson.remoting.UserRequest.perform(UserRequest.java:103)
      at hudson.remoting.UserRequest.perform(UserRequest.java:47)
      at hudson.remoting.Request$2.run(Request.java:236)
      at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
      at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
      at java.util.concurrent.FutureTask.run(Unknown Source)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
      at hudson.remoting.Engine$1$1.run(Engine.java:54)
      at java.lang.Thread.run(Unknown Source)
      Caused by: java.io.IOException: CreateProcess error=2, The system cannot find
      the file specified
      at java.lang.ProcessImpl.create(Native Method)
      at java.lang.ProcessImpl.<init>(Unknown Source)
      at java.lang.ProcessImpl.start(Unknown Source)
      ... 17 more
      Archiving artifacts
      Collecting JWSDP SQE reports

        Attachments

          Activity

          kohsuke Kohsuke Kawaguchi added a comment -

          You need to have cygwin\bin in your PATH.

          I'll update the plugin to handle this more gracefully.

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in hudson
          User: : kohsuke
          Path:
          trunk/hudson/plugins/cygpath/src/main/java/hudson/plugins/cygpath/CygpathLauncherDecorator.java
          http://fisheye4.cenqua.com/changelog/hudson/?cs=20980
          Log:
          [FIXED JENKINS-4275] Detect the location of Cygwin from registry so that Hudson can always discover the exact location of cygpath.exe.


            People

            • Assignee:
              Unassigned
              Reporter:
              hyau hyau
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: