Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-4327

Add automatic installation support for binaries

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Won't Fix
    • Component/s: tfs-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      Add automatic installation for Teamprise and opentf clients. Investigate if MS tools can
      be automatic installed.

        Attachments

          Activity

          cuberoot cuberoot added a comment -

          How much of a chore would it be to implement this? I can take a look if you dont mind?

          cuberoot cuberoot added a comment -

          It appears a ToolInstallation would be needed.

          I've got the source from SVN and I've got it setup with Maven and Eclipse. I am able to run the tests, but I get 2 errors. Is this normal?

          Tests in error:
          testThatPollingTfsDoesNotThrowNPE(hudson.plugins.tfs.TeamFoundationServerScmIntegrationTest)
          testThatLogSetContainsCheckedInByUserReference(hudson.plugins.tfs.model.ChangeLogSetIntegrationTest)

          Both with very similar Exceptions:
          org.apache.maven.embedder.MavenEmbedderException: Cannot lookup required component.
          at hudson.maven.MavenEmbedder.start(MavenEmbedder.java:733)
          at org.jvnet.hudson.test.HudsonTestCase$4.decorateHome(HudsonTestCase.java:792)
          at org.jvnet.hudson.test.HudsonTestCase.newHudson(HudsonTestCase.java:299)
          at org.jvnet.hudson.test.HudsonTestCase.setUp(HudsonTestCase.java:222)
          at junit.framework.TestCase.runBare(TestCase.java:132)
          at junit.framework.TestResult$1.protect(TestResult.java:110)
          at junit.framework.TestResult.runProtected(TestResult.java:128)
          at junit.framework.TestResult.run(TestResult.java:113)
          at junit.framework.TestCase.run(TestCase.java:124)
          at junit.framework.TestSuite.runTest(TestSuite.java:232)
          at junit.framework.TestSuite.run(TestSuite.java:227)
          at org.junit.internal.runners.JUnit38ClassRunner.run(JUnit38ClassRunner.java:91)
          at org.apache.maven.surefire.junit4.JUnit4TestSet.execute(JUnit4TestSet.java:62)
          at org.apache.maven.surefire.suite.AbstractDirectoryTestSuite.executeTestSet(AbstractDirectoryTestSuite.java:140)
          at org.apache.maven.surefire.suite.AbstractDirectoryTestSuite.execute(AbstractDirectoryTestSuite.java:127)
          at org.apache.maven.surefire.Surefire.run(Surefire.java:177)
          at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
          at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
          at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
          at java.lang.reflect.Method.invoke(Method.java:597)
          at org.apache.maven.surefire.booter.SurefireBooter.runSuitesInProcess(SurefireBooter.java:345)
          at org.apache.maven.surefire.booter.SurefireBooter.main(SurefireBooter.java:1009)
          Caused by: org.codehaus.plexus.component.repository.exception.ComponentLookupException: Unable to lookup component 'org.apache.maven.lifecycle.LifecycleExecutor', it could not be started
          at org.codehaus.plexus.DefaultPlexusContainer.lookup(DefaultPlexusContainer.java:339)
          at org.codehaus.plexus.embed.Embedder.lookup(Embedder.java:78)
          at hudson.maven.MavenEmbedder.start(MavenEmbedder.java:711)
          ... 21 more
          Caused by: org.codehaus.plexus.component.repository.exception.ComponentLifecycleException: Error starting component
          at org.codehaus.plexus.component.manager.AbstractComponentManager.startComponentLifecycle(AbstractComponentManager.java:109)
          at org.codehaus.plexus.component.manager.AbstractComponentManager.createComponentInstance(AbstractComponentManager.java:95)
          at org.codehaus.plexus.component.manager.ClassicSingletonComponentManager.getComponent(ClassicSingletonComponentManager.java:92)
          at org.codehaus.plexus.DefaultPlexusContainer.lookup(DefaultPlexusContainer.java:331)
          ... 23 more
          Caused by: org.codehaus.plexus.personality.plexus.lifecycle.phase.PhaseExecutionException: Error composing component
          at org.codehaus.plexus.personality.plexus.lifecycle.phase.CompositionPhase.execute(CompositionPhase.java:33)
          at org.codehaus.plexus.lifecycle.AbstractLifecycleHandler.start(AbstractLifecycleHandler.java:101)
          at org.codehaus.plexus.component.manager.AbstractComponentManager.startComponentLifecycle(AbstractComponentManager.java:105)
          ... 26 more
          Caused by: org.codehaus.plexus.component.composition.CompositionException: Component composition failed. No field of type: 'interface org.apache.maven.project.MavenProjectBuilder' exists in class 'org.apache.maven.lifecycle.LifecycleExecutorInterceptor'. Component: role: 'org.apache.maven.lifecycle.LifecycleExecutor', implementation: 'org.apache.maven.lifecycle.LifecycleExecutorInterceptor'
          at org.codehaus.plexus.component.composition.FieldComponentComposer.getFieldByType(FieldComponentComposer.java:305)
          at org.codehaus.plexus.component.composition.FieldComponentComposer.findMatchingField(FieldComponentComposer.java:204)
          at org.codehaus.plexus.component.composition.FieldComponentComposer.assembleComponent(FieldComponentComposer.java:62)
          at org.codehaus.plexus.component.composition.DefaultComponentComposerManager.assembleComponent(DefaultComponentComposerManager.java:68)
          at org.codehaus.plexus.DefaultPlexusContainer.composeComponent(DefaultPlexusContainer.java:1486)
          at org.codehaus.plexus.personality.plexus.lifecycle.phase.CompositionPhase.execute(CompositionPhase.java:29)
          ... 28 more

          Any ideas? My apologies if this is a common setup step that Im missing.

          evernat evernat added a comment -

          the exception in the previous comment was fixed, see JENKINS-3706

          redsolo redsolo added a comment -

          have you looked into this any further? It would be very nice to have in the plugin.

          oli_at_jsi Olivier Dagenais added a comment -

          No longer applicable as we're using the TFS SDK for Java and no tool needs to be installed.


            People

            • Assignee:
              redsolo redsolo
              Reporter:
              redsolo redsolo
            • Votes:
              2 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: