Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-43557

Can't run emulator "PANIC: Missing emulator engine program for 'x86' CPU." after clean install Android Studio 2.3.1

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Duplicate
    • Labels:
      None
    • Environment:
    • Similar Issues:

      Description

      Current behaviour

      I could not run emulator with android-emulator-plugin 2.15. It shows "PANIC: Missing emulator engine program for 'x86' CPU." and never starts emulator.

      Workaround

      It worked after I did these two steps.

      1. Add to global Jenkins environment variables:

      LD_LIBRARY_PATH=$LD_LIBRARY_PATH:$ANDROID_HOME/tools/lib

      2. Add to android-emulator-plugin->Advanced->Emulator options:

      -engine auto

      I found somehow this stackoverflow question helpful.

      I guess adding QEMU2 support would solve the problem (ref. JENKINS-40178)

        Attachments

          Issue Links

            Activity

            dominicmarmion Dominic Marmion added a comment -

            Any update on fixing this issue?

             

            sergiomira Sergio Mira added a comment -

            Adding a check to not use "-engine classic" with the latest SDK tools does the trick for us:

            https://github.com/jenkinsci/android-emulator-plugin/pull/68

            orrc Christopher Orr added a comment -

            Going to mark this as a duplicate of the resolved QEMU2 ticket.


              People

              • Assignee:
                orrc Christopher Orr
                Reporter:
                marjanovic Dragan Marjanovic
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: