Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-4376

Details tab doesn't render Checkstyle details

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      Hudson fails to display any checkstyle details.

      • It parses the checkstyle-result.xml files and displays correct numbers in the Warning Trend and
        Summary tables.
      • The details tab is empty in the main page as well as the specific annotation type pages.
      • Checkstyle plugin version 2.12 (though problem also noticed in previous versions)
      • Hudson version 1.314
      • Perhaps it is only partially parsing the <error/> lines. Ours look like
        <error line="58" column="32" severity="warning" message="'300' is a magic number."
        source="com.puppycrawl.tools.checkstyle.checks.coding.MagicNumberCheck"/>
      • Result files generated using maven checkstyle plugin across many modules

        Attachments

        1. checkstyle-result.xml
          57 kB
        2. checkstyle-warnings.xml
          0.8 kB
        3. issue-4376.patch
          13 kB
        4. result.png
          result.png
          39 kB

          Issue Links

            Activity

            Hide
            drulli Ulli Hafner added a comment -

            Ok, thanks. I replaced the checkstyle-warnings.xml in our server with your file
            but here I get the results: see screenshot.

            Since the results are rendered via an Ajax call: do you have Java Scripts
            blocked in your Browser? Which Browser are you using? Does it work in another
            browser?

            Can you please also attach the Hudson build.xml file of the current build, maybe
            there is something wrong in that file...

            BTW: the previous results are also loaded to compute the differences between two
            builds.

            Show
            drulli Ulli Hafner added a comment - Ok, thanks. I replaced the checkstyle-warnings.xml in our server with your file but here I get the results: see screenshot. Since the results are rendered via an Ajax call: do you have Java Scripts blocked in your Browser? Which Browser are you using? Does it work in another browser? Can you please also attach the Hudson build.xml file of the current build, maybe there is something wrong in that file... BTW: the previous results are also loaded to compute the differences between two builds.
            Hide
            kennedy2009 kennedy2009 added a comment -

            We see this on both Safari 4 and Firefox 3. Javascript is enabled and Firebug reports no js errors.
            However, I will investigate js execution further...

            Show
            kennedy2009 kennedy2009 added a comment - We see this on both Safari 4 and Firefox 3. Javascript is enabled and Firebug reports no js errors. However, I will investigate js execution further...
            Hide
            kennedy2009 kennedy2009 added a comment -

            So sorry, looks like a problem on our side. Bypassing a proxy server seems to fix the problem.
            Still not sure why it is affecting the js when the js appears to be fetched correctly, but not your prob.

            Thanks for you help.

            Show
            kennedy2009 kennedy2009 added a comment - So sorry, looks like a problem on our side. Bypassing a proxy server seems to fix the problem. Still not sure why it is affecting the js when the js appears to be fetched correctly, but not your prob. Thanks for you help.
            Hide
            drulli Ulli Hafner added a comment -

            Ok, I see. If I remember correctly, another user also had some problems when
            using a proxy server.

            Actually I'm just using the YUI and bubbles library to dynamically load the
            results. There seems to be an incompatibility with these libraries and Hudson
            that cause these problems.

            Show
            drulli Ulli Hafner added a comment - Ok, I see. If I remember correctly, another user also had some problems when using a proxy server. Actually I'm just using the YUI and bubbles library to dynamically load the results. There seems to be an incompatibility with these libraries and Hudson that cause these problems.
            Hide
            drulli Ulli Hafner added a comment -

            I don't see a way to prevent that when using the YUI libraries.

            Show
            drulli Ulli Hafner added a comment - I don't see a way to prevent that when using the YUI libraries.

              People

              • Assignee:
                drulli Ulli Hafner
                Reporter:
                kennedy2009 kennedy2009
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: