Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-44200

Failed to scout hudson.plugins.cobertura.MavenCoberturaPublisher

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: cobertura-plugin
    • Labels:
      None
    • Environment:
      Jenkins 2.59
    • Similar Issues:

      Description

      After upgrading Jenkins from 2.58 to 2.59 I got the following trace in the log (the plugin still seems to be working though):

      Failed to scout hudson.plugins.cobertura.MavenCoberturaPublisher
      java.lang.ClassNotFoundException: hudson.maven.MavenReporter
      	at jenkins.util.AntClassLoader.findClassInComponents(AntClassLoader.java:1374)
      	at jenkins.util.AntClassLoader.findClass(AntClassLoader.java:1327)
      	at jenkins.util.AntClassLoader.loadClass(AntClassLoader.java:1080)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
      Caused: java.lang.NoClassDefFoundError: hudson/maven/MavenReporter
      	at java.lang.ClassLoader.defineClass1(Native Method)
      	at java.lang.ClassLoader.defineClass(ClassLoader.java:763)
      	at jenkins.util.AntClassLoader.defineClassFromData(AntClassLoader.java:1140)
      	at hudson.ClassicPluginStrategy$AntClassLoader2.defineClassFromData(ClassicPluginStrategy.java:884)
      	at jenkins.util.AntClassLoader.getClassFromStream(AntClassLoader.java:1311)
      	at jenkins.util.AntClassLoader.findClassInComponents(AntClassLoader.java:1364)
      	at jenkins.util.AntClassLoader.findClass(AntClassLoader.java:1327)
      	at sun.reflect.GeneratedMethodAccessor3.invoke(Unknown Source)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      	at java.lang.reflect.Method.invoke(Method.java:498)
      	at jenkins.ClassLoaderReflectionToolkit.invoke(ClassLoaderReflectionToolkit.java:44)
      	at jenkins.ClassLoaderReflectionToolkit._findClass(ClassLoaderReflectionToolkit.java:81)
      	at hudson.PluginManager$UberClassLoader.findClass(PluginManager.java:1864)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
      	at net.java.sezpoz.IndexItem.element(IndexItem.java:134)
      Caused: java.lang.InstantiationException
      	at net.java.sezpoz.IndexItem.element(IndexItem.java:146)
      	at hudson.ExtensionFinder$Sezpoz.scout(ExtensionFinder.java:656)
      	at hudson.ClassicPluginStrategy.findComponents(ClassicPluginStrategy.java:471)
      	at hudson.ExtensionList.load(ExtensionList.java:365)
      	at hudson.ExtensionList.ensureLoaded(ExtensionList.java:303)
      	at hudson.ExtensionList.getComponents(ExtensionList.java:168)
      	at jenkins.model.Jenkins$8.onInitMilestoneAttained(Jenkins.java:1119)
      	at jenkins.InitReactorRunner$1.onAttained(InitReactorRunner.java:82)
      	at org.jvnet.hudson.reactor.ReactorListener$Aggregator.onAttained(ReactorListener.java:104)
      	at org.jvnet.hudson.reactor.Reactor$1.run(Reactor.java:176)
      	at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
      	at java.lang.Thread.run(Thread.java:745)
      
      Failed to load hudson.plugins.cobertura.MavenCoberturaPublisher
      java.lang.ClassNotFoundException: hudson.maven.MavenReporter
      	at jenkins.util.AntClassLoader.findClassInComponents(AntClassLoader.java:1374)
      	at jenkins.util.AntClassLoader.findClass(AntClassLoader.java:1327)
      	at jenkins.util.AntClassLoader.loadClass(AntClassLoader.java:1080)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
      Caused: java.lang.NoClassDefFoundError: hudson/maven/MavenReporter
      	at java.lang.ClassLoader.defineClass1(Native Method)
      	at java.lang.ClassLoader.defineClass(ClassLoader.java:763)
      	at jenkins.util.AntClassLoader.defineClassFromData(AntClassLoader.java:1140)
      	at hudson.ClassicPluginStrategy$AntClassLoader2.defineClassFromData(ClassicPluginStrategy.java:884)
      	at jenkins.util.AntClassLoader.getClassFromStream(AntClassLoader.java:1311)
      	at jenkins.util.AntClassLoader.findClassInComponents(AntClassLoader.java:1364)
      	at jenkins.util.AntClassLoader.findClass(AntClassLoader.java:1327)
      	at sun.reflect.GeneratedMethodAccessor3.invoke(Unknown Source)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      	at java.lang.reflect.Method.invoke(Method.java:498)
      	at jenkins.ClassLoaderReflectionToolkit.invoke(ClassLoaderReflectionToolkit.java:44)
      	at jenkins.ClassLoaderReflectionToolkit._findClass(ClassLoaderReflectionToolkit.java:81)
      	at hudson.PluginManager$UberClassLoader.findClass(PluginManager.java:1864)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
      	at net.java.sezpoz.IndexItem.element(IndexItem.java:134)
      Caused: java.lang.InstantiationException
      	at net.java.sezpoz.IndexItem.element(IndexItem.java:146)
      	at hudson.ExtensionFinder$Sezpoz._find(ExtensionFinder.java:620)
      	at hudson.ExtensionFinder$Sezpoz.find(ExtensionFinder.java:609)
      	at hudson.ExtensionFinder$GuiceFinder.<init>(ExtensionFinder.java:257)
      	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
      	at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)
      	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
      	at java.lang.reflect.Constructor.newInstance(Constructor.java:423)
      	at java.lang.Class.newInstance(Class.java:442)
      	at net.java.sezpoz.IndexItem.instance(IndexItem.java:181)
      	at hudson.ExtensionFinder$Sezpoz._find(ExtensionFinder.java:634)
      	at hudson.ExtensionFinder$Sezpoz.find(ExtensionFinder.java:609)
      	at hudson.ClassicPluginStrategy.findComponents(ClassicPluginStrategy.java:477)
      	at hudson.ExtensionList.load(ExtensionList.java:365)
      	at hudson.ExtensionList.ensureLoaded(ExtensionList.java:303)
      	at hudson.ExtensionList.getComponents(ExtensionList.java:168)
      	at jenkins.model.Jenkins$8.onInitMilestoneAttained(Jenkins.java:1119)
      	at jenkins.InitReactorRunner$1.onAttained(InitReactorRunner.java:82)
      	at org.jvnet.hudson.reactor.ReactorListener$Aggregator.onAttained(ReactorListener.java:104)
      	at org.jvnet.hudson.reactor.Reactor$1.run(Reactor.java:176)
      	at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
      	at java.lang.Thread.run(Thread.java:745)
      

      (The failed to load trace repeats a few more times)

        Attachments

          Issue Links

            Activity

            danielbeck Daniel Beck added a comment -

            https://github.com/jenkinsci/cobertura-plugin/blob/1cf41b4edc3cf62fcc3d2295fdd53c9574ec4fbf/src/main/java/hudson/plugins/cobertura/MavenCoberturaPublisher.java#L240 needs to

            @Extension(optional = true)

            and then the entire plugin should declare an optional dependency on the Maven Plugin, so Jenkins dependency management can do its job (AFAICT). This seems to be missing, probably pulled in transitively (optional dependency on dashboard-view, which depends on maven-plugin).
            https://github.com/jenkinsci/cobertura-plugin/blob/master/pom.xml

            cb_tes_global Constantin Bugneac added a comment - - edited

            I confirm that this exception persists on Jenkins 2.103 (which is annoying) despite no maven is installed/used at all.

            floriankammermann Florian Kammermann added a comment - - edited

            Same error here, with different behaviour:

            • jenkins gui was not accessible anymore
            • the log showed, that the error was printing in a loop
            • additionally I had a Guice container error
            • after restart the loop was gone
            • the error was shown on startup

            the logs

            
            Apr 12, 2018 6:26:45 AM hudson.ExtensionFinder$GuiceFinder$SezpozModule configure
            WARNING: Failed to load hudson.plugins.cobertura.MavenCoberturaPublisher
            java.lang.InstantiationException: java.lang.NoClassDefFoundError: hudson/maven/MavenReporter
                    at net.java.sezpoz.IndexItem.element(IndexItem.java:146)
            --------
            Caused by: java.lang.NoClassDefFoundError: hudson/maven/MavenReporter
                    at java.lang.ClassLoader.defineClass1(Native Method)
                    at java.lang.ClassLoader.defineClass(ClassLoader.java:763)
            --------
            Caused by: java.lang.ClassNotFoundException: hudson.maven.MavenReporter
                    at jenkins.util.AntClassLoader.findClassInComponents(AntClassLoader.java:1374)
                    at jenkins.util.AntClassLoader.findClass(AntClassLoader.java:1327)
                    at jenkins.util.AntClassLoader.loadClass(AntClassLoader.java:1080)
            ---------
            Apr 12, 2018 6:26:45 AM hudson.ExtensionFinder$GuiceFinder <init>
            SEVERE: Failed to create Guice container from all the plugins
            com.google.common.util.concurrent.ExecutionError: com.google.common.util.concurrent.ExecutionError: java.lang.NoClassDefFoundError: Lorg/jenkinsci/main/modules/instance_identity/InstanceIdentity;
                    at com.google.common.cache.LocalCache$Segment.get(LocalCache.java:2232)
                    at com.google.common.cache.LocalCache.get(LocalCache.java:3965)
                    at com.google.common.cache.LocalCache.getOrLoad(LocalCache.java:3969)
            ----------
            Caused by: com.google.common.util.concurrent.ExecutionError: java.lang.NoClassDefFoundError: Lorg/jenkinsci/main/modules/instance_identity/InstanceIdentity;
                    at com.google.common.cache.LocalCache$Segment.get(LocalCache.java:2232)
                    at com.google.common.cache.LocalCache.get(LocalCache.java:3965)
                    at com.google.common.cache.LocalCache.getOrLoad(LocalCache.java:3969)
            -----------
            Caused by: java.lang.NoClassDefFoundError: Lorg/jenkinsci/main/modules/instance_identity/InstanceIdentity;
                    at java.lang.Class.getDeclaredFields0(Native Method)
                    at java.lang.Class.privateGetDeclaredFields(Class.java:2583)
                    at java.lang.Class.getDeclaredFields(Class.java:1916)
            -----------
            Caused by: java.lang.ClassNotFoundException: org.jenkinsci.main.modules.instance_identity.InstanceIdentity
                    at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
                    at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
                    at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
            
            

            jenkins version: 2.89.4
            maven integration: 3.1
            Cobetura: 1.12

            nuzz Matt Nuzzaco added a comment -

            Yep I'm hitting this as well..... running Jenkins via helm chart in a k8s cluster:

            Jenkins:2.119

             

            Plugins:

            • kubernetes:1.6.0
            • credentials-binding:1.16
            • git:3.8.0
            • github:1.29.0
            • github-branch-source:2.3.4
            • ghprb:1.40.0
            • google-login:1.3.1
            • ansicolor:0.5.2
            • cobertura:1.12
            • junit:1.24
            • timestamper:1.8.9
            • workflow-aggregator:2.5
            • blueocean:1.5.0
            • pipeline-aws:1.26
            • workflow-cps:2.52
            • jira:2.5.2

             

            jenkins-jenkins-86b5c6456f-sfrpz jenkins-jenkins May 07, 2018 3:04:02 PM hudson.ExtensionFinder$Sezpoz _find
            jenkins-jenkins-86b5c6456f-sfrpz jenkins-jenkins WARNING: Failed to load hudson.plugins.cobertura.MavenCoberturaPublisher
            jenkins-jenkins-86b5c6456f-sfrpz jenkins-jenkins java.lang.InstantiationException: java.lang.NoClassDefFoundError: hudson/maven/MavenReporter
            jenkins-jenkins-86b5c6456f-sfrpz jenkins-jenkins at net.java.sezpoz.IndexItem.element(IndexItem.java:146)
            jenkins-jenkins-86b5c6456f-sfrpz jenkins-jenkins at hudson.ExtensionFinder$Sezpoz._find(ExtensionFinder.java:620)
            jenkins-jenkins-86b5c6456f-sfrpz jenkins-jenkins at hudson.ExtensionFinder$Sezpoz.find(ExtensionFinder.java:609)
            jenkins-jenkins-86b5c6456f-sfrpz jenkins-jenkins at hudson.ClassicPluginStrategy.findComponents(ClassicPluginStrategy.java:482)
            jenkins-jenkins-86b5c6456f-sfrpz jenkins-jenkins at hudson.ExtensionList.load(ExtensionList.java:380)
            jenkins-jenkins-86b5c6456f-sfrpz jenkins-jenkins at hudson.ExtensionList.ensureLoaded(ExtensionList.java:318)
            jenkins-jenkins-86b5c6456f-sfrpz jenkins-jenkins at hudson.ExtensionList.getComponents(ExtensionList.java:183)
            jenkins-jenkins-86b5c6456f-sfrpz jenkins-jenkins at jenkins.model.Jenkins$6.onInitMilestoneAttained(Jenkins.java:1094)
            jenkins-jenkins-86b5c6456f-sfrpz jenkins-jenkins at jenkins.InitReactorRunner$1.onAttained(InitReactorRunner.java:83)
            jenkins-jenkins-86b5c6456f-sfrpz jenkins-jenkins at org.jvnet.hudson.reactor.ReactorListener$Aggregator.lambda$onAttained$3(ReactorListener.java:102)
            jenkins-jenkins-86b5c6456f-sfrpz jenkins-jenkins at org.jvnet.hudson.reactor.ReactorListener$Aggregator.run(ReactorListener.java:109)
            jenkins-jenkins-86b5c6456f-sfrpz jenkins-jenkins at org.jvnet.hudson.reactor.ReactorListener$Aggregator.onAttained(ReactorListener.java:102)
            jenkins-jenkins-86b5c6456f-sfrpz jenkins-jenkins at org.jvnet.hudson.reactor.Reactor$1.run(Reactor.java:177)
            jenkins-jenkins-86b5c6456f-sfrpz jenkins-jenkins at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117)
            jenkins-jenkins-86b5c6456f-sfrpz jenkins-jenkins at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
            jenkins-jenkins-86b5c6456f-sfrpz jenkins-jenkins at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
            jenkins-jenkins-86b5c6456f-sfrpz jenkins-jenkins at java.lang.Thread.run(Thread.java:748)
            jenkins-jenkins-86b5c6456f-sfrpz jenkins-jenkins Caused by: java.lang.NoClassDefFoundError: hudson/maven/MavenReporter
            jenkins-jenkins-86b5c6456f-sfrpz jenkins-jenkins at java.lang.ClassLoader.defineClass1(Native Method)
            jenkins-jenkins-86b5c6456f-sfrpz jenkins-jenkins at java.lang.ClassLoader.defineClass(ClassLoader.java:763)
            jenkins-jenkins-86b5c6456f-sfrpz jenkins-jenkins at jenkins.util.AntClassLoader.defineClassFromData(AntClassLoader.java:1140)
            jenkins-jenkins-86b5c6456f-sfrpz jenkins-jenkins at hudson.ClassicPluginStrategy$AntClassLoader2.defineClassFromData(ClassicPluginStrategy.java:847)
            jenkins-jenkins-86b5c6456f-sfrpz jenkins-jenkins at jenkins.util.AntClassLoader.getClassFromStream(AntClassLoader.java:1311)
            jenkins-jenkins-86b5c6456f-sfrpz jenkins-jenkins at jenkins.util.AntClassLoader.findClassInComponents(AntClassLoader.java:1364)
            jenkins-jenkins-86b5c6456f-sfrpz jenkins-jenkins at jenkins.util.AntClassLoader.findClass(AntClassLoader.java:1327)
            jenkins-jenkins-86b5c6456f-sfrpz jenkins-jenkins at sun.reflect.GeneratedMethodAccessor3.invoke(Unknown Source)
            jenkins-jenkins-86b5c6456f-sfrpz jenkins-jenkins at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
            jenkins-jenkins-86b5c6456f-sfrpz jenkins-jenkins at java.lang.reflect.Method.invoke(Method.java:498)
            jenkins-jenkins-86b5c6456f-sfrpz jenkins-jenkins at jenkins.ClassLoaderReflectionToolkit.invoke(ClassLoaderReflectionToolkit.java:44)
            jenkins-jenkins-86b5c6456f-sfrpz jenkins-jenkins at jenkins.ClassLoaderReflectionToolkit._findClass(ClassLoaderReflectionToolkit.java:81)
            jenkins-jenkins-86b5c6456f-sfrpz jenkins-jenkins at hudson.PluginManager$UberClassLoader.findClass(PluginManager.java:1872)
            jenkins-jenkins-86b5c6456f-sfrpz jenkins-jenkins at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
            jenkins-jenkins-86b5c6456f-sfrpz jenkins-jenkins at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
            jenkins-jenkins-86b5c6456f-sfrpz jenkins-jenkins at net.java.sezpoz.IndexItem.element(IndexItem.java:134)
            jenkins-jenkins-86b5c6456f-sfrpz jenkins-jenkins ... 16 more
            jenkins-jenkins-86b5c6456f-sfrpz jenkins-jenkins Caused by: java.lang.ClassNotFoundException: hudson.maven.MavenReporter
            jenkins-jenkins-86b5c6456f-sfrpz jenkins-jenkins at jenkins.util.AntClassLoader.findClassInComponents(AntClassLoader.java:1374)
            jenkins-jenkins-86b5c6456f-sfrpz jenkins-jenkins at jenkins.util.AntClassLoader.findClass(AntClassLoader.java:1327)
            jenkins-jenkins-86b5c6456f-sfrpz jenkins-jenkins at jenkins.util.AntClassLoader.loadClass(AntClassLoader.java:1080)
            jenkins-jenkins-86b5c6456f-sfrpz jenkins-jenkins at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
            jenkins-jenkins-86b5c6456f-sfrpz jenkins-jenkins ... 32 more
            jenkins-jenkins-86b5c6456f-sfrpz jenkins-jenkins
            jeffpearce Jeff Pearce added a comment -

            Fixed in release 1.12.1


              People

              • Assignee:
                Unassigned
                Reporter:
                johnv John V
              • Votes:
                18 Vote for this issue
                Watchers:
                23 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: