Details

    • Type: Bug
    • Status: Open (View Workflow)
    • Priority: Blocker
    • Resolution: Unresolved
    • Component/s: envinject-plugin
    • Labels:
      None
    • Environment:
      AIX slave
      Jenkins: 2.61
      envinject: 2.1
    • Similar Issues:

      Description

      None of my builds running on AIX will start, they error out with

       

      org.jenkinsci.lib.envinject.EnvInjectException: java.io.InvalidClassException: org.jenkinsci.plugins.envinject.service.EnvironmentVariablesNodeLoader$1; local class incompatible: stream classdesc serialVersionUID = -2630906866550529145, local class serialVersionUID = -2721064306957331564
      	at org.jenkinsci.plugins.envinject.service.EnvironmentVariablesNodeLoader.gatherEnvVarsForNode(EnvironmentVariablesNodeLoader.java:95)
      	at org.jenkinsci.plugins.envinject.EnvInjectListener.loadEnvironmentVariablesNode(EnvInjectListener.java:80)
      	at org.jenkinsci.plugins.envinject.EnvInjectListener.setUpEnvironment(EnvInjectListener.java:43)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.createLauncher(AbstractBuild.java:528)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:448)
      	at hudson.model.Run.execute(Run.java:1735)
      	at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
      	at hudson.model.ResourceController.execute(ResourceController.java:97)
      	at hudson.model.Executor.run(Executor.java:405)
      Caused by: java.io.InvalidClassException: org.jenkinsci.plugins.envinject.service.EnvironmentVariablesNodeLoader$1; local class incompatible: stream classdesc serialVersionUID = -2630906866550529145, local class serialVersionUID = -2721064306957331564
      	at java.io.ObjectStreamClass.initNonProxy(ObjectStreamClass.java:702)
      	at java.io.ObjectInputStream.readNonProxyDesc(ObjectInputStream.java:1705)
      	at java.io.ObjectInputStream.readClassDesc(ObjectInputStream.java:1600)
      	at java.io.ObjectInputStream.readOrdinaryObject(ObjectInputStream.java:1875)
      	at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1432)
      	at java.io.ObjectInputStream.readObject(ObjectInputStream.java:428)
      	at hudson.remoting.UserRequest.deserialize(UserRequest.java:217)
      	at hudson.remoting.UserRequest.perform(UserRequest.java:131)
      	at hudson.remoting.UserRequest.perform(UserRequest.java:50)
      	at hudson.remoting.Request$2.run(Request.java:336)
      	at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:68)
      	at java.util.concurrent.FutureTask.run(FutureTask.java:277)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1153)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
      	at java.lang.Thread.run(Thread.java:785)
      	at ......remote call to AIXslave(Native Method)
      	at hudson.remoting.Channel.attachCallSiteStackTrace(Channel.java:1545)
      	at hudson.remoting.UserResponse.retrieve(UserRequest.java:253)
      	at hudson.remoting.Channel.call(Channel.java:830)
      	at hudson.FilePath.act(FilePath.java:1081)
      	at org.jenkinsci.plugins.envinject.service.EnvironmentVariablesNodeLoader.gatherEnvVarsForNode(EnvironmentVariablesNodeLoader.java:64)
      

        Attachments

          Activity

          Hide
          oleg_nenashev Oleg Nenashev added a comment -

          No response from the reporter. Unassigning

          Show
          oleg_nenashev Oleg Nenashev added a comment - No response from the reporter. Unassigning
          Hide
          aflat aflat added a comment -

          You never gave me anything to try, what response were you looking for?

          Show
          aflat aflat added a comment - You never gave me anything to try, what response were you looking for?
          Hide
          stevenm Steven Murphy added a comment -

          I am seeing this on my AIX agents too, all my other agents (Windows, SunOS, HP, Red Hat & Suse) are ok.

          • Jenkins: 2.60.2
          • envinject : 2.1.3
          Show
          stevenm Steven Murphy added a comment - I am seeing this on my AIX agents too, all my other agents (Windows, SunOS, HP, Red Hat & Suse) are ok. Jenkins: 2.60.2 envinject : 2.1.3
          Hide
          trent_dailey Trent Dailey added a comment -

          Also had the same issue on AIX build agents.  No issues with RHEL, Windows, iOS build agents.

          • Jenkins v2.46.2
          • EnvInject v2.1.3

          This was resolved by rolling back to version 2.0 of the EnvInject plugin.

          Show
          trent_dailey Trent Dailey added a comment - Also had the same issue on AIX build agents.  No issues with RHEL, Windows, iOS build agents. Jenkins v2.46.2 EnvInject v2.1.3 This was resolved by rolling back to version 2.0 of the EnvInject plugin.
          Hide
          srimanoj_kandala Mallikarjuna Manoj Kandala added a comment -

          In our case, when the issue was reported then the version of java was "1.8.0" , and now it has been upgraded to version "1.8.0_144" on the AIX slave node, to resolve the issue.

          Show
          srimanoj_kandala Mallikarjuna Manoj Kandala added a comment - In our case, when the issue was reported then the version of java was "1.8.0" , and now it has been upgraded to version "1.8.0_144" on the AIX slave node, to resolve the issue.

            People

            • Assignee:
              Unassigned
              Reporter:
              aflat aflat
            • Votes:
              5 Vote for this issue
              Watchers:
              10 Start watching this issue

              Dates

              • Created:
                Updated: