Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-44502

Jenkins 2.46.3 LTS apt (Debian/Ubuntu) package incorrectly has Java 8 as dependency

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: packaging
    • Labels:
      None
    • Environment:
      - Ubuntu 14.04 (but also affects any other OS that uses .deb package and has no Java 8 available)
      - Jenkins 2.46.3 LTS
      - Java 7
    • Similar Issues:

      Description

      The latest Jenkins 2.46.3 LTS apt package has the following dependency set: default-jre-headless|java8-runtime-headless
      Where default-jre-headless depends on version 2:1.8 or higher (>= 2:1.8).

      This dependency seems to be incorrect as, for now, this is only valid for the weekly Jenkins releases (which is incompatible with Java 7 and lower).
      The 2.46.3 release notes also do not mention this change.

      Because of this dependency Jenkins 2.46.3 cannot be installed on Ubuntu 14.04 as it lacks an official Java8 package.

        Attachments

          Issue Links

            Activity

            jbogers Jeroen Bogers added a comment -

            For workarounds on Ubuntu 14.04 (that involve installing Java 8), see the fixes proposed in https://issues.jenkins-ci.org/browse/JENKINS-43629

            oleg_nenashev Oleg Nenashev added a comment -

            Caused by JENKINS-44504. All packages have been released from a wrong (aka latest) packaging baseline

            danielbeck Daniel Beck added a comment -

            Duplicate of JENKINS-44504 which more completely describes the problem.

            mcrowe Mike Crowe added a comment -

            This problem also affects Debian 8 (Jessie) which is the current stable version. Java 8 is available in debian-backports, but I'd rather not install it unnecessarily.

            The following packages have unmet dependencies:
            jenkins : Depends: default-jre-headless (>= 2:1.8) but 2:1.7-52 is to be installed or
            java8-runtime-headless but it is not installable

            jgrant216 Jeff G added a comment -

            I just updated our Jenkins Ubuntu JRE7 Master today from 2.46.1 to 2.46.3 and think I ran into this issue.

            Am I looking at this being released as part of 2.46.4+?  It seems like the jre dependency needed to be updated back to JRE7.

            oleg_nenashev Oleg Nenashev added a comment -

            Jeff G Please see the linked issue. You are commenting in the closed duplicate

            vorona Anatolii Vorona added a comment -

             

            this problem has returned

            $ lsb_release -a
            No LSB modules are available.
            Distributor ID: Ubuntu
            Description: Ubuntu 14.04.5 LTS
            Release: 14.04
            Codename: trusty
            $ sudo apt show jenkins 
            Package: jenkins
            Version: 2.60.3
            Priority: extra
            Section: devel
            Maintainer: Kohsuke Kawaguchi <kk@kohsuke.org>
            Installed-Size: 70.7 MB
            Depends: daemon, adduser, procps, psmisc, net-tools, default-jre-headless (>= 2:1.8) | java8-runtime-headless
            

             

            oleg_nenashev Oleg Nenashev added a comment -

            Anatolii Vorona LTS 2.60.x  requires Java 8. See the notice here: https://jenkins.io/changelog-stable/#v2.60.1


              People

              • Assignee:
                kohsuke Kohsuke Kawaguchi
                Reporter:
                jbogers Jeroen Bogers
              • Votes:
                1 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: