Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-44745

Jenkins and HP Application Automation Tools - Failed to start TEST_SET , run id: com.hp.alm.platform.exception.CTdException: Failed to prepare timeslot for run. handleCreateAction

    Details

    • Similar Issues:

      Description

      Hi all,

      In Jenkins I have installed and configured the plugin "HP Application Automation Tools".

      I have created a job with build step "Execute HP tests using HP ALM Lab Management" (1_build_step.jpg).

      When I start this job, I get in "Console Output" the following message: Started by user anonymousBuilding in workspace C:\Program Files (x86)\Jenkins\workspace\UFT Job1Logged in successfully to ALM Server https://<myAlmUrl>.com/qcbin/ using <myAlmUsername>Executing TEST_SET ID: 2105 in <almDomain>/<almProject> Description: Failed to start TEST_SET ID:2105, run id: com.hp.alm.platform.exception.CTdException: Failed to prepare timeslot for run. handleCreateAction; Note: You can run only functional test sets and build verification suites using this plugin. Check to make sure that the configured ID is valid (and that it is not a performance test ID).Empty ResultsResult Status: UNSTABLEBuild step 'Execute HP tests using HP ALM Lab Management' changed build result to UNSTABLERecording test resultsNone of the test reports contained any resultRunResultRecorder: didn't find any test results to recordFinished: UNSTABLE

       

      I have free time slots in ALM (2_timeslots_alm.jpg), also there are two available hosts, from which the one with highest priority ce13822 works fine with "HP ALM Lab Service plugin" and autologon (3_testing hosts.jpg).

      Could You please help me how to configure it to make it possible to trigger the running of test cases from Jenkins? Thank You.

      Tomasz

        Attachments

        1. 1_build_step.jpg
          1_build_step.jpg
          240 kB
        2. 2_timeslots_alm.jpg
          2_timeslots_alm.jpg
          328 kB
        3. 3_testing hosts.jpg
          3_testing hosts.jpg
          299 kB
        4. image-2017-07-24-15-36-50-873.png
          image-2017-07-24-15-36-50-873.png
          10 kB

          Activity

          Hide
          evanchen Evan Chen added a comment -

          Hi Tomasz,

          Not sure if the problem still concerns you. As the error info indicated, Lab management running need "Functional Test Set" or "Build Verification Suite". Please check the detail of you test set on ALM to see if it's a functional test set. If not, you need to create a new test set of type "functional test" or use "Execute Functional Test from ALM" with existing test set. It has no limitation of test set but it cannot auto assign host via ALM.

          I'm closing this issue. But if it's not the case as I addressed, please reopen it.

           

          Thanks,

          Evan

          Show
          evanchen Evan Chen added a comment - Hi Tomasz, Not sure if the problem still concerns you. As the error info indicated, Lab management running need "Functional Test Set" or "Build Verification Suite". Please check the detail of you test set on ALM to see if it's a functional test set. If not, you need to create a new test set of type "functional test" or use "Execute Functional Test from ALM" with existing test set. It has no limitation of test set but it cannot auto assign host via ALM. I'm closing this issue. But if it's not the case as I addressed, please reopen it.   Thanks, Evan

            People

            • Assignee:
              evanchen Evan Chen
              Reporter:
              tomaszfulek Tomasz Fulek
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: