Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-4632

MSTest plugin does not parse Visual Studio 2010 results

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Fixed
    • Component/s: mstest-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      The Visual Studio 2010 results file format has changed and that change prevents
      the Hudson MSTest plugin from parsing the MSTest results file.

      The Visual Studio 2008 MSTest schema was
      http://microsoft.com/schemas/VisualStudio/TeamTest/2006.

      The Visual Studio 2010 beta MSTest schema is
      http://microsoft.com/schemas/VisualStudio/TeamTest/2010.

      I added basic support for the VS 2010 schema and it seems to present results.
      My changes are not extracting the buildName correctly, but they do seem to
      extract the number of tests, number of failures, number skipped, and the
      individual results. However, I have not performed detailed testing of my
      changes to present individual results.

        Attachments

          Activity

          markewaite Mark Waite added a comment -

          Created an attachment (id=941)
          Proposed patch to support VS 2010

          markewaite Mark Waite added a comment -

          I realized while typing the issue report that I have not done enough exploring
          of the output, or reading of the VS 2010 TRX file to assure that the results are
          correctly displayed when a test fails. I'll add additional information when I
          learn more.

          markewaite Mark Waite added a comment -

          I confirmed that the proposed patch presents the same information from VS 2008
          and VS 2010 tests for tests which fail an assertion and for tests which fail a
          test without failing an assertion (because, for instance, the test throws an
          unexpected exception).

          acmarques acmarques added a comment -

          Thanks for your patch markewaite!

          It worked well for all tests I did using MSTest2010 schema and didn't break compatibility with the old tests the plugin already have.
          Applied now. Will be released in version 0.6.

          mjm maria jose m added a comment -

          I have tested the patch and it doesn't work. Also, Jenkins will delete my new xsl file when it is restarted.
          Could you get a version 0.7 with this new template to see if it works correctly, please?

          Thanks,

          mjm maria jose m added a comment -

          I have tested the patch and it doesn't work. Could you tell me how to work these patch, please?

          mjm maria jose m added a comment -

          This file is valid to parse Visual Studio 2010 results.

          You have to copy this file in the path where is installed the plugin mstest in Jenkins.
          For example:
          C:\Program Files\Jenkins\plugins\mstest\WEB-INF\classes\hudson\plugins\mstest

          markewaite Mark Waite added a comment -

          Confirmed fixed long ago.


            People

            • Assignee:
              mjm maria jose m
              Reporter:
              markewaite Mark Waite
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: