Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-4645

FindBugs plugin should ignore aborted builds

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: findbugs-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      The plugin calculates new warnings against the previous build even it is
      aborted. This can lead to unstable or failed builds even if there are no 'real'
      new warnings.

      BTW: some more logging in the build logger would be nice at the plugin doesn't
      seem to log that it is setting a build to unstable or so.

        Attachments

          Issue Links

            Activity

            drulli Ulli Hafner added a comment -

            Are you using the m2 project type? (I think for m2 jobs there is API to write
            messages to the build log.)

            drulli Ulli Hafner added a comment -

            Sorry, of course I meant "there is no API"...

            kutzi kutzi added a comment -

            Im using the m2 project type, but I wonder why there should not be an API to
            write to the build log as I'm using the Warnings plugin, too, and that one is
            definitely writing something into the build log.

            drulli Ulli Hafner added a comment -

            OK, that was only half the truth The long story: the warnings plug-in has no
            special handling for the m2 job. It uses the same class for freestyle and m2
            jobs. My other plug-ins handle m2 jobs differently, i.e. there is a new class to
            report these results. Here you have a logger only during the build, but not
            after the build (where the evaluations takes place...)

            drulli Ulli Hafner added a comment -

            Isn't that the same as issue #3514?

            kutzi kutzi added a comment -

            d'oh, sure it is

                • This issue has been marked as a duplicate of 3514 ***

              People

              • Assignee:
                drulli Ulli Hafner
                Reporter:
                kutzi kutzi
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: