Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-46566

Multibranch scan uses backslash instead of slash when scanning for Jenkinsfile

    Details

    • Similar Issues:

      Description

      Starting with version 2.14 of the multibranch plugin, the scanning of a branch is done on Windows using a backslash "\';  This cause perforce to fail when trying to find the Jenkinsfile, and the multibranch project ends up finding nothing.

       

      Starting in 2.14 (also tested with 2.15 and 2.16), I see this:

       

       
      [jeu. août 31 10:25:40 EDT 2017] Starting branch indexing...
      (p4):cmd:... p4 streams //beacon-osdk/...
      p4 streams //beacon-osdk/...
      
      (p4):stop:4
      (p4):cmd:... p4 client -o jenkins-master
      p4 client -o jenkins-master
      
      (p4):stop:4
      (p4):cmd:... p4 info
      p4 info
      
      (p4):stop:5
      (p4):cmd:... p4 files //beacon-osdk/v5.0-main\Jenkinsfile
      p4 files //beacon-osdk/v5.0-main\Jenkinsfile
      
      //beacon-osdk/v5.0-main\Jenkinsfile - no such file(s).
      
      (p4):stop:6
      ‘Jenkinsfile’ not found
      

       

      Whereas in 2.13, I had this:

       

       

      [jeu. août 31 10:25:40 EDT 2017] Starting branch indexing...
      (p4):cmd:... p4 streams //beacon-osdk/...
      p4 streams //beacon-osdk/...
      (p4):stop:4
      (p4):cmd:... p4 client -o jenkins-master
      p4 client -o jenkins-master
      (p4):stop:4
      (p4):cmd:... p4 info
      p4 info
      (p4):stop:5
      (p4):cmd:... p4 files //beacon-osdk/v5.0-main/Jenkinsfile
      p4 files //beacon-osdk/v5.0-main/Jenkinsfile
      //beacon-osdk/v5.0-main/Jenkinsfile#1 - add change 98200 (text)
      (p4):stop:6
       ‘Jenkinsfile’ found
      

       

       

       

       

        Attachments

          Issue Links

            Activity

            Hide
            gpetit Gaspard Petit added a comment -

            False alarm, the problem is with the P4 Plugin

            Show
            gpetit Gaspard Petit added a comment - False alarm, the problem is with the P4 Plugin
            Hide
            gpetit Gaspard Petit added a comment -

            The problem is with the P4 Plugin, somewhere between version 1.7.1 and 1.7.4

            Show
            gpetit Gaspard Petit added a comment - The problem is with the P4 Plugin, somewhere between version 1.7.1 and 1.7.4

              People

              • Assignee:
                vaimr Denis Saponenko
                Reporter:
                gpetit Gaspard Petit
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: