Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-46683

Multibranch pipeline failing at Checkout SCM step (unable to resolve tag)

    Details

    • Similar Issues:

      Description

      Hello,

      I'm facing a strange issue since the last upgrade (when Blue Ocean was released in 1.2.0).

      I tried to downgrade almost everything (both jenkins to 2.60.2 and every plugins who might be related to git/scm). But I couldn't make it work again...

      The issue occurs whenever I try to launch a build or "Scan Multibranch Pipeline Now".

      Here is the errog log I get everytime :

      Démarré par l'utilisateur segdim
       > git rev-parse --is-inside-work-tree # timeout=10
      Setting origin to https://git_url/ORG/repo.git
       > git config remote.origin.url https://git_url/ORG/repo.git # timeout=10
      Fetching origin...
      Fetching upstream changes from origin
       > git --version # timeout=10
       > git fetch --tags --progress origin +refs/heads/*:refs/remotes/origin/*
      hudson.plugins.git.GitException: Command "git fetch --tags --progress origin +refs/heads/*:refs/remotes/origin/*" returned status code 1:
      stdout:
      stderr: error: unable to resolve reference refs/tags/20170825-fc97b4e: Argument invalide
      Depuis https://git_url/ORG/repo.git
       ! [nouvelle étiquette] 20170825-fc97b4e -> 20170825-fc97b4e  (impossible de mettre à jour la référence locale)
      
          at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.launchCommandIn(CliGitAPIImpl.java:1924)
          at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.launchCommandWithCredentials(CliGitAPIImpl.java:1643)
          at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.access$300(CliGitAPIImpl.java:71)
          at org.jenkinsci.plugins.gitclient.CliGitAPIImpl$1.execute(CliGitAPIImpl.java:352)
          at jenkins.plugins.git.AbstractGitSCMSource.doRetrieve(AbstractGitSCMSource.java:344)
          at jenkins.plugins.git.AbstractGitSCMSource.retrieve(AbstractGitSCMSource.java:358)
          at jenkins.scm.api.SCMSource.fetch(SCMSource.java:564)
          at org.jenkinsci.plugins.workflow.multibranch.SCMBinder.create(SCMBinder.java:95)
          at org.jenkinsci.plugins.workflow.job.WorkflowRun.run(WorkflowRun.java:263)
          at hudson.model.ResourceController.execute(ResourceController.java:97)
          at hudson.model.Executor.run(Executor.java:405)
      Finished: FAILURE
      

      I also tried to run manually the git commands SCM Checkout Jenkins is using :

      git fetch --tags --progress origin +refs/heads/*:refs/remotes/origin/*
      

      It works fine for me and the tag 20170825-fc97b4e does exist inside my repository.

      I tried on multiple branches and other repositories and I got the same result.

      Thanks

        Attachments

          Activity

          Hide
          stephenconnolly Stephen Connolly added a comment -

          This is happening for all our repositories and we don't use special characters for filenames (only - _ and .)

          By any chance do you have a shared global library defined? You'll either need the advanced behaviour there too or use the PR I have created and add Discover Tags to the shared library definition

          Show
          stephenconnolly Stephen Connolly added a comment - This is happening for all our repositories and we don't use special characters for filenames (only - _ and .) By any chance do you have a shared global library defined? You'll either need the advanced behaviour there too or use the PR I have created and add Discover Tags to the shared library definition
          Hide
          stephenconnolly Stephen Connolly added a comment -

          Should be fixed with the current release of the git plugin AIUI

          Show
          stephenconnolly Stephen Connolly added a comment - Should be fixed with the current release of the git plugin AIUI
          Hide
          stephenconnolly Stephen Connolly added a comment -

          Please reopen if not fixed in current git plugin release

          Show
          stephenconnolly Stephen Connolly added a comment - Please reopen if not fixed in current git plugin release
          Hide
          akmjenkins ASHOK MOHANTY added a comment -

          We are using git-client 3.0 and git plugin 4.0. Facing this error intermittently (inside a JNLP node). For cloning we are using a generic LDAP user without password.

          And/or please let me know the matching ticket where I can update this issue !!
          > GitLab: Your account has been blocked.
          fatal: Could not read from remote repository.

          On re-try/re-play it works fine.

          Show
          akmjenkins ASHOK MOHANTY added a comment - We are using git-client 3.0 and git plugin 4.0. Facing this error intermittently (inside a JNLP node). For cloning we are using a generic LDAP user without password. And/or please let me know the matching ticket where I can update this issue !! > GitLab: Your account has been blocked. fatal: Could not read from remote repository. On re-try/re-play it works fine.
          Hide
          markewaite Mark Waite added a comment -

          ASHOK MOHANTY asking unrelated questions on closed issues is unlikely to get you the help you want. Questions are best asked in the chat channels or on the mailing lists.

          Show
          markewaite Mark Waite added a comment - ASHOK MOHANTY asking unrelated questions on closed issues is unlikely to get you the help you want. Questions are best asked in the chat channels or on the mailing lists .

            People

            • Assignee:
              Unassigned
              Reporter:
              segdim Dimitri SEGARD
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: