Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-47734

Install Jenkins hangs indefinetly on Version 2.46.2 also in version 2.73.2

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: core
    • Environment:
    • Similar Issues:

      Description

      Hi,

       

      I am having issues while trying to install Jenkins Version 2.46.2. I have provided the initial user id

      and password but it hangs forever. Attached is the screen shot and the nohup.out.

       

      I don't see any error messages in the logs dir other than started and finished messages plus there is

      no log file at all with the current state of jenkins.

       

      Screenshot-1.png with intial password and and then it hangs indefinitely in screenshot.png.

       

      Given below are the contents of the logs dir under jenkins

      drwxrwxr-x.  3 esmadmin esmadmin     4096 Oct 27 09:58 logs

       

      [esmadmin@identity_server7 jenkins]$ cd logs
      [esmadmin@identity_server7 logs]$ pwd
      /u01/jenkins/logs
      [esmadmin@identity_server7 logs]$ ls -latr
      total 12
      drwxrwxr-x.  3 esmadmin esmadmin 4096 Oct 27 09:58 .
      drwxrwxr-x.  2 esmadmin esmadmin 4096 Oct 30 11:04 tasks
      drwxrwxr-x. 11 esmadmin esmadmin 4096 Oct 30 11:42 ..
      [esmadmin@identity_server7 logs]$ cd tasks/
      [esmadmin@identity_server7 tasks]$ ls -altr
      total 24
      drwxrwxr-x. 3 esmadmin esmadmin 4096 Oct 27 09:58 ..
      rw-rw-r-. 1 esmadmin esmadmin   90 Oct 27 09:58 Download metadata.log.3
      rw-rw-r-. 1 esmadmin esmadmin   87 Oct 27 10:53 Download metadata.log.2
      rw-rw-r-. 1 esmadmin esmadmin   89 Oct 30 09:40 Download metadata.log.1
      rw-rw-r-. 1 esmadmin esmadmin   86 Oct 30 10:17 Download metadata.log
      drwxrwxr-x. 2 esmadmin esmadmin 4096 Oct 30 11:04 .
      [esmadmin@identity_server7 tasks]$ cat Download\ metadata.log
      Started at Mon Oct 30 10:17:12 EDT 2017
      Finished at Mon Oct 30 10:17:12 EDT 2017. 5ms
      [esmadmin@identity_server7 tasks]$ cat Download\ metadata.log.1
      Started at Mon Oct 30 09:39:57 EDT 2017
      Finished at Mon Oct 30 09:40:07 EDT 2017. 9510ms
      [esmadmin@identity_server7 tasks]$ cat Download\ metadata.log.2
      Started at Fri Oct 27 10:53:08 EDT 2017
      Finished at Fri Oct 27 10:53:08 EDT 2017. 24ms
      [esmadmin@identity_server7 tasks]$ cat Download\ metadata.log.3
      Started at Fri Oct 27 09:58:38 EDT 2017
      Finished at Fri Oct 27 09:58:49 EDT 2017. 11274ms

       

        Attachments

        1. jenkins_nohup.out
          5 kB
          Jagan Tirumalai
        2. jenkins_thread_dump.txt
          24 kB
          Jagan Tirumalai
        3. Screenshot.png
          71 kB
          Jagan Tirumalai
        4. Screenshot-1.png
          109 kB
          Jagan Tirumalai

          Issue Links

            Activity

            oleg_nenashev Oleg Nenashev added a comment -

            Jagan Tirumalai what is the difference from the issue you report in JENKINS-34708?

            jet_1974 Jagan Tirumalai added a comment -

            Oleg,

             

            Its in a diff version of Jenkins 2.46.2. Also the environment might be different to recreate the issue.

            jet_1974 Jagan Tirumalai added a comment - - edited

            Oleg,

             

            Any idea what's happening with this issue? Any luck as to what is going on in the jenkins server?

            Were you able to reproduce the problem?

            Is anyone else working on this issue?

             

            Thx

            pbasov Pavel Basov added a comment -

            I've had the same issue, turns out jenkins couldn't check for internet connectivity against www.google.com

            Changed connectionCheckUrl in jenkins/home/updates/default.json to a different value and it successfully started to bootstrap.

            Maybe have something in logs, the only way to find out was to check the API json response that is returned to the webui:

            "status":"ok","data":{"updatesite":"OK","internet":"CHECKING"}}

            oleg_nenashev Oleg Nenashev added a comment - - edited

            google.com is blocked in China at least IIRC. It seems to be a valid defect.We should be checking connectivity against Jenkins resources for sure.

            CC Keith Zantow Daniel Beck


              People

              • Assignee:
                Unassigned
                Reporter:
                jet_1974 Jagan Tirumalai
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: