Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-48022

NullPointer when trying to retrieve Configuration

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: claim-plugin
    • Labels:
      None
    • Environment:
      jenkins 2.90
      claim plugin 2.10
    • Similar Issues:

      Description

      After a build failure due to failed unit tests following Exception is logged:

      ERROR: Build step failed with exception
      java.lang.NullPointerException
      	at hudson.plugins.claim.AbstractClaimBuildAction.<init>(AbstractClaimBuildAction.java:43)
      	at hudson.plugins.claim.ClaimBuildAction.<init>(ClaimBuildAction.java:14)
      	at hudson.plugins.claim.ClaimPublisher.perform(ClaimPublisher.java:62)
      	at hudson.plugins.claim.ClaimPublisher.perform(ClaimPublisher.java:53)
      	at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:744)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:690)
      	at hudson.model.Build$BuildExecution.post2(Build.java:186)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:635)
      	at hudson.model.Run.execute(Run.java:1749)
      	at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
      	at hudson.model.ResourceController.execute(ResourceController.java:97)
      	at hudson.model.Executor.run(Executor.java:421)
      Build step 'Allow broken build claiming' marked build as failure
      

      Looks like ClaimConfig.get() is null.

      Seems like in claim plugin version 2.7 everything was fine (but I'm not sure about this)

        Attachments

          Issue Links

            Activity

            Hide
            npfistner Norbert Pfistner added a comment -

            First quick test looks promising.
            I'll do some more testing ...

            Show
            npfistner Norbert Pfistner added a comment - First quick test looks promising. I'll do some more testing ...
            Hide
            greybird Arnaud TAMAILLON added a comment -

            Thanks for your feedback.

            Let me know if you think we can close this issue, or if you think the fix is incomplete.

            Show
            greybird Arnaud TAMAILLON added a comment - Thanks for your feedback. Let me know if you think we can close this issue, or if you think the fix is incomplete.
            Hide
            npfistner Norbert Pfistner added a comment -

            We had round about 40 jobs running the last 21 hours without any problem concerning the claim plugin.

            Looks like the bug has been fixed.

            Many Thank's!

            Show
            npfistner Norbert Pfistner added a comment - We had round about 40 jobs running the last 21 hours without any problem concerning the claim plugin. Looks like the bug has been fixed. Many Thank's!
            Hide
            greybird Arnaud TAMAILLON added a comment -

            Thanks for your confirmation & help on this topic!

            Show
            greybird Arnaud TAMAILLON added a comment - Thanks for your confirmation & help on this topic!
            Hide
            greybird Arnaud TAMAILLON added a comment -

            Fixes in 2.11

            Show
            greybird Arnaud TAMAILLON added a comment - Fixes in 2.11

              People

              • Assignee:
                greybird Arnaud TAMAILLON
                Reporter:
                npfistner Norbert Pfistner
              • Votes:
                5 Vote for this issue
                Watchers:
                8 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: